Bluetooth pairing issues with new iPhone4 and '06 Prius

Discussion in 'Gen 2 Prius Audio and Electronics' started by neilw, Feb 11, 2011.

  1. neilw

    neilw Junior Member

    Joined:
    Jul 30, 2006
    42
    5
    0
    Just got a Verizon iPhone4 (finally) and am having bluetooth pairing issues with my '06 Prius (non-Nav). The behavior is not quite what I've seen described on other threads, so I don't know what try here. Note that my old junkie dumbphone worked reliably with the Prius over Bluetooth.

    Anyway, when I first paired the phone with the car it worked perfectly. But the next time I got into the car, it wouldn't pair. The car said "Bluetooth connection unsuccessful" and the iPhone, inside the Bluetooth settings page, eventually said something equivalent. Eventually, what worked was to turn bluetooth off then on again on the iPhone. The next time I came back into the car, I tried deleting the Prius from the iPhone, and re-pairing it from scratch. That worked too.

    But obviously I need this thing to automatically pair every time I get in the car. Anyone have any suggestions? I don't see any settings anywhere that would let me alter the behavior of either the car or the phone.
     
  2. GeekEV

    GeekEV Member

    Joined:
    Sep 12, 2006
    417
    14
    0
    Location:
    NorCal, USA
    Vehicle:
    2006 Prius
    Model:
    N/A
    Huh. I have an AT&T iPhone 4 (which, granted has slightly different electronics) and it pairs just fine with my '06 Prius. I wonder if you have a defective phone? You could try taking it back to the Apple Store and see what they say. I suppose it's possible they botched things up in the Verizon version, do not know.
     
  3. neilw

    neilw Junior Member

    Joined:
    Jul 30, 2006
    42
    5
    0
    Hard to imagine it's a defect, but ya never know. I'll have to see if any others are having this with their Verizon phones. Annoying....
     
  4. neilw

    neilw Junior Member

    Joined:
    Jul 30, 2006
    42
    5
    0
  5. MRoland

    MRoland New Member

    Joined:
    Jun 3, 2005
    14
    0
    0
    Location:
    North Carolina
    I am at more basics steps in pairing my Verizon iPhone 4 with my '05 Prius. It was very clear what to do with my last phone - but don't know what codes to key in. Thanks for any feedback from those who have succeeded.
     
  6. MRoland

    MRoland New Member

    Joined:
    Jun 3, 2005
    14
    0
    0
    Location:
    North Carolina
    All - see this site for details on how to pair and troubleshooting. It seems the '05 Pri will not pair w/iPhone- due to its ancient hardware. If someone has discovered otherwise let me know. My iPhone message said "give up on this device"!!
     
  7. MRoland

    MRoland New Member

    Joined:
    Jun 3, 2005
    14
    0
    0
    Location:
    North Carolina
  8. MRoland

    MRoland New Member

    Joined:
    Jun 3, 2005
    14
    0
    0
    Location:
    North Carolina
    '05 Prius pairs just fine with iPhone. Don't be in such a big hurry like I was. Easy, easy.
     
  9. neilw

    neilw Junior Member

    Joined:
    Jul 30, 2006
    42
    5
    0
    Just to close this one out, my phone is now pairing fine with the Prius, every day. The only thing that changed is that I went through a process with Verizon to initialize my voice mail; they had mis-provisioned it when activating my phone. During that process, I had to power cycle the phone a couple of times.

    So, for whatever reason, all is well now.
     
Loading...