Cam shaft error

Discussion in 'Gen 2 Prius Care, Maintenance and Troubleshooting' started by Smardaz, May 2, 2017.

  1. Smardaz

    Smardaz Junior Member

    Joined:
    Dec 20, 2012
    18
    4
    0
    Vehicle:
    2008 Prius
    Model:
    Five
    So every once in while I get a check engine light and when I connect my reader it comes up as a cam shaft position error. It does not stick around long. Anyone else get this? Should I be concerned?
     
  2. TWOPrius

    TWOPrius Junior Member

    Joined:
    Feb 15, 2012
    48
    11
    0
    Location:
    Tampa
    Vehicle:
    2011 Prius
    Model:
    III
  3. WilDavis

    WilDavis Senior Member

    Joined:
    Feb 4, 2014
    2,422
    2,061
    49
    Location:
    Top RH Corner of RH Coast on L side of The Pond
    Vehicle:
    2009 Prius
    Model:
    II
    Well, last time I saw one of those, I checked under the bonnet, and the cam-shaft was exactly where I though it was supposed to be, so I have to admit that I ignored it! ...but seriously (folks) I wouldn't worry too much about it if it's only a "one-off", but you might want to look out for it just in case it's the start of something bad! BTW Welcome to PriusChat!!
     
  4. Patrick Wong

    Patrick Wong DIY Enthusiast

    Joined:
    Mar 8, 2008
    18,095
    6,080
    0
    Location:
    Green Valley, AZ
    Vehicle:
    2015 Prius
    Model:
    Two
    What fault code is logged?

    This sounds like an intermittent wiring harness connection to the camshaft position sensor.
     
    johnjohnchu likes this.
  5. johnjohnchu

    johnjohnchu Member

    Joined:
    Jan 12, 2008
    210
    94
    0
    Location:
    Los Angeles, CA
    Vehicle:
    2006 Prius
    Model:
    N/A
    I do get similar error code approximately a couple times a year. I think it was P0011. Every time, I just cleared the code and moved on. Also, changed the timing control valve filter, but it did not resolve the issue. Plan to look into the possibility of loose electric connection as suggested by Pat. It is a low priority issue for me since it rarely happens.
     
  6. Smardaz

    Smardaz Junior Member

    Joined:
    Dec 20, 2012
    18
    4
    0
    Vehicle:
    2008 Prius
    Model:
    Five
    Same code as Johnjohnchu, i wasn't too worried but twice today I've gotten red exclamations and "problem" on the screen while going downhill, i do not know what the hell is going on
     
  7. Patrick Wong

    Patrick Wong DIY Enthusiast

    Joined:
    Mar 8, 2008
    18,095
    6,080
    0
    Location:
    Green Valley, AZ
    Vehicle:
    2015 Prius
    Model:
    Two
    When was the last time you checked your engine oil level on the dipstick?
     
    johnjohnchu, valde3 and Mendel Leisk like this.
Loading...