Car not turning on+check engine light. Help!

Discussion in 'Gen 2 Prius Care, Maintenance and Troubleshooting' started by Es19, Jan 9, 2020.

  1. Es19

    Es19 New Member

    Joined:
    Jan 9, 2020
    2
    0
    0
    Location:
    NJ
    Vehicle:
    2009 Prius
    Model:
    Base
    I'm a first time driver/ car owner. Bought a 2009 Prius with 83k miles last week. Today I was in the car exploring it. I must've done something because now it won't turn on and the check engine light is on and beeping. Here's what I did:
    I had it in park and had the heat on for ~30min.Everything was fine till I opened the fuel door, removed the cap, then put it back on. The car turned on but wouldn't drive. All the gear and fuel symbols were flashing along with the park button light. I tightened the cap till it clicked, turned the car off then on. Still the same problem. I decided to ignore it for the time being. But then the car stopped turning on at all. Shortly after, the check engine light tuned on and was beeping. The smart key wouldn't lock or unlock it, the interior lights were very dim when I tried to turn them on.

    Did I buy a broken car? should I try to return it? Did I break something? What can I do?
     
  2. JC91006

    JC91006 Senior Member

    Joined:
    Nov 10, 2013
    15,025
    7,698
    0
    Location:
    Los Angeles, CA
    Vehicle:
    2010 Prius
    Model:
    V
    This sounds like you drained the battery while you had the heat on for 30 minutes. I'm assuming the car was not "ON" when you did this.

    You'll most likely need to charge the 12v battery, then test it. If it fails, you'll need a new battery. Let's just hope that's all that's wrong with the car
     
  3. Es19

    Es19 New Member

    Joined:
    Jan 9, 2020
    2
    0
    0
    Location:
    NJ
    Vehicle:
    2009 Prius
    Model:
    Base
    Isn't the engine supposed to turn on automatically to charge the 12v battery if the car is in park?
     
  4. JC91006

    JC91006 Senior Member

    Joined:
    Nov 10, 2013
    15,025
    7,698
    0
    Location:
    Los Angeles, CA
    Vehicle:
    2010 Prius
    Model:
    V
    Only if you left the car in Ready mode (turned on)
     
    SFO likes this.
Loading...