Check Hybrid System

Discussion in 'Gen 3 Prius Care, Maintenance & Troubleshooting' started by Kyleallenftw, Oct 10, 2020.

  1. Kyleallenftw

    Kyleallenftw New Member

    Joined:
    Oct 10, 2020
    2
    2
    0
    Location:
    Topeka, KS
    Vehicle:
    2010 Prius
    Model:
    III
    I've got a 2010 Prius III with just under 160K miles on it. The other day, I turned my car on and got a message saying "Check Hybrid System." I can't put the car into gear- only neutral. The gas engine won't start up.

    I've been troubleshooting as best I can; starting with pulling the orange hybrid battery plug. I put a brand new 12V in it, topped up the gas, and cleaned out some residual oil from the air intake.

    Still no luck. Any ideas of what might be happening?
     
  2. Grit

    Grit Senior Member

    Joined:
    Aug 22, 2017
    4,124
    3,196
    1
    Location:
    Wilkes Land
    Vehicle:
    2012 Prius
    Model:
    Four
    Grab the cel codes otherwise you’ll be blind troubleshooting.
     
    pjksr02 likes this.
  3. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    90,019
    40,380
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    check the battery cooling fan
     
  4. pjksr02

    pjksr02 Active Member

    Joined:
    Nov 2, 2009
    516
    213
    2
    Location:
    Connecticut
    Vehicle:
    2010 Prius
    Model:
    III
    If you don't have a good code reader, now is the time to get one.

    Have you had all your warranty repairs completed?

    It could be the Intelligent Power Module ("inverter"), if yours is original. Not sure if the enhanced warranty is still covering these. But when mine went out, I couldn't start the system at all, or shift. So, maybe the hybrid battery is more likely.
     
  5. Kyleallenftw

    Kyleallenftw New Member

    Joined:
    Oct 10, 2020
    2
    2
    0
    Location:
    Topeka, KS
    Vehicle:
    2010 Prius
    Model:
    III
    Got a code P0A0D - High Voltage System Interlock Circuit High.

    Bought a salvaged inverter off eBay and swapped it out. Car started right up.

    Problem solved.
     
    pjksr02 and bisco like this.
  6. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    90,019
    40,380
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    congrats!(y)
     
Loading...