Cluster lights out/ no energy data on MFD

Discussion in 'Gen 2 Prius Care, Maintenance and Troubleshooting' started by Priusprofit, Jul 7, 2018.

  1. Priusprofit

    Priusprofit Member

    Joined:
    Mar 2, 2018
    94
    30
    0
    Location:
    Long island
    Vehicle:
    2005 Prius
    Model:
    II
    Hello everyone! I recently purchased my 7th prius! It is a 2005 with 264k miles.

    The car needed a lot of small repairs that I've done on other priuses before (strut, ignition coil, coolant temperature sensor, coolant flow control valve, oxygen sensor)

    BUT! This morning I got into the car to begin working on them all and 90% of the cluster lights were out and the MFD had no energy data.

    The cluster only displays the check engine light and turn signal arrows when turned on. Everything on the MFD works it just does not display energy information.

    I have removed a prius cluster before and it was terrible so I'm really hoping that's not the case with this prius.

    Any insight to what might be causing this issue is greatly appreciated.

    The check engine light is coolant/o2 sensor related and the car still runs and drives.
     

    Attached Files:

  2. hchu1

    hchu1 Active Member

    Joined:
    Sep 28, 2006
    315
    126
    0
    Location:
    Houston, Tx.
    Vehicle:
    2014 Prius v wagon
    Model:
    Two
    You have a dead combo meter. You can check the many threads on the forum. I understand these guys do good work, check them out, give them a call.

    Prius Speedometer Replacement
     
    Priusprofit and ITBland like this.
  3. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    88,043
    39,244
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    start with the 12 volt. if that is okay, you might be sool.:unsure:
     
    Priusprofit likes this.
Loading...