Cylinder #2 and #3 low compression, leaking cylinder and low oil pressure

Discussion in 'Gen 3 Prius Care, Maintenance & Troubleshooting' started by DIRTYSteez, Apr 15, 2021.

  1. DIRTYSteez

    DIRTYSteez New Member

    Joined:
    Apr 15, 2021
    2
    1
    0
    Location:
    Palm Springs
    Vehicle:
    2013 Prius
    Model:
    Five
    What was your findings in regards to your compression on cylinder #2? Did you pull the head?
    Was the valve stuck

    I have the exact same issues as you codes showing for cyl. 2 and 3 and multiple misfire and almost to the "T" same test results along with air escaping thru the exhaust.
    But I have an added bonus I also had the Yellow Triangle of Death pop up and say Low oil Pressure.... But I'm not an " " who doesn't maintain there vehicle and check my oil ..I myself service all my vehicles nobody else touches them.
    So I get home check the oil then drain the oil .....completely full. So i refill with oil clear the codes everything seems and sounds fine when I start it and drive it down the road . I then hit an empty back road (paved) where im going to put the pedal to the floor but not instantly I get up to 28-30 mph and I can faintly hear the engine starting to sound like a rattle can so i let off goes away go back up to 30-32 now and I hear it again so then I just hit the gas at this point and Yellow Triangle of Death Comes On again and sounds like rattle can city. An just before the Yellow Triangle of Death showed itself the misfire codes reappeared along with o2 sensor 1 showing low input signal.
    and my vehicle is 2013 Prius @236K which again very similar to yours (op).
     
  2. Mendel Leisk

    Mendel Leisk Sand Pounder

    Joined:
    Oct 17, 2010
    45,964
    32,825
    80
    Location:
    Greater Vancouver, British Columbia, Canada
    Vehicle:
    2010 Prius
    Model:
    Touring
    Have you looked into Exhaust Gas Recirculation cleaning? With 236k miles it WILL be needed.
     
  3. dolj

    dolj Senior Member

    Joined:
    May 14, 2012
    5,870
    3,123
    0
    Location:
    Wellington, New Zealand
    Vehicle:
    2007 Prius
    Model:
    N/A
    Yours is a Gen 3 and the OPs is a 2007 so a Gen 2. In this regard, not very similar at all, once the discussion goes in the EGR direction.
     
    DIRTYSteez and Mendel Leisk like this.
  4. mr_guy_mann

    mr_guy_mann Senior Member

    Joined:
    Sep 3, 2020
    1,195
    492
    0
    Location:
    NJ-USA
    Vehicle:
    2006 Prius
    Model:
    Four
    Besides likely having EGR system problems on your GEN3, you might want to have someone use a mechanical gauge to confirm or deny if your engine does have low oil pressure. Ain't much point worrying about misfires if the engine is dying.

    Posted via the PriusChat mobile app.
     
  5. DIRTYSteez

    DIRTYSteez New Member

    Joined:
    Apr 15, 2021
    2
    1
    0
    Location:
    Palm Springs
    Vehicle:
    2013 Prius
    Model:
    Five
    Appreciate the replys ...but yeah I went ahead and yanked the engine out ....so I went ahead and decided to build whole new complete engine from top to bottom even down to every single nut and bolt... Fun project


    The Old Engine ... which is still complete on an engine stand if anyone needs one
    IMG_1282.JPG
    New Block , Upper Oil Pan, and Cylinder Head
    IMG_1304.JPG
    The New Engine
    64089337438__890FD2B1-E556-47F4-9FEE-31FA765D15E2.JPG
     
    Mendel Leisk likes this.
  6. Mendel Leisk

    Mendel Leisk Sand Pounder

    Joined:
    Oct 17, 2010
    45,964
    32,825
    80
    Location:
    Greater Vancouver, British Columbia, Canada
    Vehicle:
    2010 Prius
    Model:
    Touring
    That’s a complete 4th gen engine, or bits and bobs?
     
Loading...