Dashboard Display don't work

Discussion in 'Gen 3 Prius Care, Maintenance & Troubleshooting' started by WartburgFan, Dec 21, 2018.

  1. WartburgFan

    WartburgFan New Member

    Joined:
    Dec 21, 2018
    1
    0
    0
    Location:
    Germany
    Vehicle:
    2011 Prius
    Model:
    III
    Hello.
    I have a 2011 Prius 3, with 500.000km.

    My Display don't work. When i press the ignition button, the Dashboard display is dark and no beep sound appears. (lights on, doors open).

    My 12V Battery is new.
    When its over 20°C, the display works, on cold days, it is completely dark. Sometimes, when i have drive over 50km and the car is warm, the display start up and the Prius logo appears.

    What i have checked:
    -12V Battery
    -solder joints on the display
    -everything re-soldered
    -Pin 1 and 3 on the big connector have 12V (have someone a current circuit plan?)
    -the capacitors dont have voltage applied
    -I have a Laboratory power supply. I put on pin 1 and 3 voltage, but nothing happened


    WhatsApp Image 2018-12-21 at 14.19.04.jpeg WhatsApp Image 2018-12-21 at 14.16.21.jpeg Can someone help me?
     
  2. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    94,763
    42,979
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    welcome!

    maybe a bad lcd display?
     
  3. Raytheeagle

    Raytheeagle Senior Member

    Joined:
    Jul 1, 2016
    11,188
    15,315
    0
    Location:
    Bay Area, California
    Vehicle:
    2019 Prius Prime
    Model:
    Prime Plus
    Any moisture ever get in there?

    All connections are tight?

    The dimmer is not all the way down?

    Any codes that could be read?
     
Loading...