engine stop working on the way, car moving on battery

Discussion in 'Gen 2 Prius Care, Maintenance and Troubleshooting' started by Yev Vo, Oct 21, 2019.

  1. Yev Vo

    Yev Vo New Member

    Joined:
    Oct 21, 2019
    3
    1
    0
    Location:
    san jose
    Vehicle:
    2008 Prius
    Model:
    II
    on my prius 2008 engine stop working after red triangle show up. car was moving only from hybrid battery till it is drain . after some time i can turn on car and engine will work for 2 -3 minutes and charge battery but then it stops work
    I did not test battery, coolant was leaking 3 days ago, after i took it to mechanic they said that now everything is okay and they add coolant

    Now engine coolant looks like empty, not sure it was dark
     
  2. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    83,650
    36,572
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    welcome!

    how many miles on her? any puddles under the car?

    did they read the trouble codes?
     
    SFO likes this.
  3. Yev Vo

    Yev Vo New Member

    Joined:
    Oct 21, 2019
    3
    1
    0
    Location:
    san jose
    Vehicle:
    2008 Prius
    Model:
    II
    it was camshaft position sensor
     
    bisco likes this.
  4. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    83,650
    36,572
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    excellent!(y)

    (i didn't know coolant could leak out of that)
     
  5. Yev Vo

    Yev Vo New Member

    Joined:
    Oct 21, 2019
    3
    1
    0
    Location:
    san jose
    Vehicle:
    2008 Prius
    Model:
    II
    coolant was leaking not because of that
     
  6. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    83,650
    36,572
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
Loading...