engine stumbling/running rough while cruising

Discussion in 'Gen 3 Prius Care, Maintenance & Troubleshooting' started by mattbatson, Sep 19, 2020.

  1. mattbatson

    mattbatson Member

    Joined:
    Feb 10, 2017
    107
    64
    0
    Location:
    asheville NC
    Vehicle:
    Other Non-Hybrid
    Model:
    N/A
    Yes
    I can try that as well

    Thanks
     
  2. mattbatson

    mattbatson Member

    Joined:
    Feb 10, 2017
    107
    64
    0
    Location:
    asheville NC
    Vehicle:
    Other Non-Hybrid
    Model:
    N/A
    It could also be that it started running rough as the software update was over due... then continued running rough for a day after as the computer had to learn the update ?
     
  3. mattbatson

    mattbatson Member

    Joined:
    Feb 10, 2017
    107
    64
    0
    Location:
    asheville NC
    Vehicle:
    Other Non-Hybrid
    Model:
    N/A
    update...she drove 15 hour round trip to see her mom

    no issues...runs great with no engine shake.

    I think it was the software update...believe it or not.

    If others on here have the shakes, they should check to make sure there are no outstanding software updates.

    I've not done a leak down or looked at the car any further due to it seemingly being fixed.

    this was just an update for FYI purposes...and thanks for all the responses.

    going to try to get her car to 300 k miles ;)
     
  4. fotomoto

    fotomoto Senior Member

    Joined:
    Apr 22, 2009
    5,244
    3,488
    0
    Location:
    So. Texas
    Vehicle:
    Other Hybrid
    What was this specific update? Inverter? It should be on the paperwork.
     
  5. mattbatson

    mattbatson Member

    Joined:
    Feb 10, 2017
    107
    64
    0
    Location:
    asheville NC
    Vehicle:
    Other Non-Hybrid
    Model:
    N/A
    I was out of town while this is was being done at the dealer ... girlfriends car

    I’ll see if my girlfriend still has the receipt
     
  6. cnc97

    cnc97 Senior Member

    Joined:
    Mar 13, 2018
    1,183
    1,332
    29
    Location:
    Evansville, IN
    Vehicle:
    2010 Prius
    Model:
    Three
    Not to be a wet blanket, but the engine/hybrid ECUS are not intelligent enough to cause a misfire issue because they are due for an update. I suspect poor quality fuel, an impending coil failure, or the previously mentioned head gasket leak. The nature of how the ICE operates, it only takes droplets of coolant to trigger a misfire. In the early stages of failure of the head gasket, droplets disappearing from the system would not show up for some time. It would certainly show up on a 15 hour round trip though. The leak down test is the most likely way to check for that. The other way, pressurize the cooling system with the rental tool that most parts houses have, while peeking in the cylinder with the rental borescope.
     
    fotomoto likes this.
Loading...