Engine suddenly seems to misfire and revs very high

Discussion in 'Gen 3 Prius Care, Maintenance & Troubleshooting' started by maggotdrowner, Jun 2, 2020.

  1. maggotdrowner

    maggotdrowner New Member

    Joined:
    Jun 2, 2020
    7
    2
    0
    Location:
    Liverpool UK
    Vehicle:
    2011 Prius
    Model:
    Active
    First may i say thanks for some great information i've found on this site.

    i have a 2011 Prius with 68k miles..a few months ago it started to misbehave.
    It starts revving and seems to misfire and shudder....it can happen when stationary or slowing down...then it just settles down again.

    A friend checked it with a diagnostic gadget and it gave the code for P0113 and P0102 relating to the Mass airflow sensor. He sprayed around the intake manifold and pipes to check for leaks, but nothing found.

    Should i just replace the mass airflow sensor?

    Thanks in advance.
     
  2. Mendel Leisk

    Mendel Leisk Sunday driver DIY’r

    Joined:
    Oct 17, 2010
    42,028
    30,121
    80
    Location:
    Greater Vancouver, British Columbia, Canada
    Vehicle:
    2010 Prius
    Model:
    Touring
    What did he spray? I'm just thinking, if it's oily, and it did manage to get sucked in, up-stream of the MAF (Mass Air Flow) sensor, it might coat it, mess it up further? There's a cleaner in North American: CRC Mass Air Flow Sensor cleaner. Not sure about UK. The CRC cleaner as far as I know is comparable to electronic contact cleaner, very pure/clean solvent. I've used on our MAF (probably not needed) and also for cleaning the innards of TV remotes and similar.

    Do you know where the MAF sensor is, just down-stream of the air filter, held on with a couple of screws 'round back of the snorkel? Easy to get to and remove.

    It's very fragile/delicate, the internal components. Just spray with correct cleaner for sure.

    It's very expensive to part replace, around $250 in the States IIRC.
     
  3. maggotdrowner

    maggotdrowner New Member

    Joined:
    Jun 2, 2020
    7
    2
    0
    Location:
    Liverpool UK
    Vehicle:
    2011 Prius
    Model:
    Active
    Thanks for the reply.
    He used the correct cleaner and did the MAF.
    The car runs fine for weeks with no problem then suddenly develops this high revs and misfire and shudder.
    They cost about £40.00 here thats $50.00 approx...wouldn't like to be paying $250.
    I recon i may as well just replace it.
    Thanks
     
    Mendel Leisk likes this.
  4. Mendel Leisk

    Mendel Leisk Sunday driver DIY’r

    Joined:
    Oct 17, 2010
    42,028
    30,121
    80
    Location:
    Greater Vancouver, British Columbia, Canada
    Vehicle:
    2010 Prius
    Model:
    Touring
    could have swore I saw over $200 USD, for either of those sensors, at McGeorge Toyota Parts. Could check later, tough in a phone.
     
  5. pjksr02

    pjksr02 Active Member

    Joined:
    Nov 2, 2009
    531
    220
    2
    Location:
    Connecticut
    Vehicle:
    2010 Prius
    Model:
    III
    The MAF sensor is about $100US. The MAP is about $200.

    The P0112 seems to refer to the intake air temperature; anyone know if the MAF sensor reads the temperature? Has there been any work done on the intake system, which may have caused a leak?
     
    Mendel Leisk likes this.
  6. maggotdrowner

    maggotdrowner New Member

    Joined:
    Jun 2, 2020
    7
    2
    0
    Location:
    Liverpool UK
    Vehicle:
    2011 Prius
    Model:
    Active
    No...no work done on the intake...

    i forgot to say...since cleaning the MAF sensor, the error codes no longer show when my friend rechecked it....... the problem is happening far less than before...maybe every few weeks or so...so the cleaning helped but not cured the problem.

    What would you advise i do next ?

    Thanks for your help..
     
  7. maggotdrowner

    maggotdrowner New Member

    Joined:
    Jun 2, 2020
    7
    2
    0
    Location:
    Liverpool UK
    Vehicle:
    2011 Prius
    Model:
    Active
    One thing know now is that it was cleaned with Carburetor cleaner,
    I fear i'm now going to be told that's wrong ?
     
  8. AzWxGuy

    AzWxGuy Weather Guy

    Joined:
    May 22, 2011
    762
    359
    0
    Location:
    Tucson, AZ
    Vehicle:
    2021 Prius
    Model:
    Limited
    When I have cleaned my MAF (very rarely) I have noticed what appears to be a thermister just out of the airflow on one side. Figures since air density changes with temperature. The component is coated with a clear brown-colored material. I would carefully inspect the electrical connector to the MAF before just parting out something that throws a code. Wander on down the wiring harness and look for insulation damage. Vehicle ever in a wreck?
     
  9. maggotdrowner

    maggotdrowner New Member

    Joined:
    Jun 2, 2020
    7
    2
    0
    Location:
    Liverpool UK
    Vehicle:
    2011 Prius
    Model:
    Active
    After buying it 12mths ago i noticed some overspray just below the front bumper, so i think it's had some damage.
    In the UK if a car is damaged beyond very minor it has to be logged and nothing is showing.
    It's interesting that the Air conditioning isn't working and i was told it's empty...not got round to getting it fixed yet.
     
Loading...