Flashing gas gauge reset not working

Discussion in 'Gen 2 Prius Technical Discussion' started by David Scott Dallas, Sep 4, 2019.

  1. David Scott Dallas

    David Scott Dallas Junior Member

    Joined:
    Oct 15, 2017
    33
    12
    0
    Location:
    Dallas
    Vehicle:
    2015 Prius
    Model:
    One
    I’ve replaced my speedometer on my 06 with 170k. The instructions that came with it said to reset the gas gauge which I did but found out later they were wrong. So it definitely wasn’t reset. But it started working and was about right as far as I could tell. I drove it a few times and all was well. Then my gas gauge started doing a double blink. That’s when I found out the actual reset constructions and I did it and it worked and stopped for a couple of days and now it’s doing it again. I know this kind of stuff has been covered but I couldn’t find anything specifically telling me about my problem. I read on here that I need to take the dash back apart and check the connections I’m just wondering before I do that and risk breaking something is there something else that I should do first?
     
  2. Skibob

    Skibob Senior Member

    Joined:
    Sep 14, 2018
    2,912
    1,484
    0
    Location:
    Northern California
    Vehicle:
    2006 Prius
    Model:
    N/A
    What did you replace your old one with? New? Rebuilt? Junkyard? If rebuilt who did the rebuilding?
     
    #2 Skibob, Sep 4, 2019
    Last edited: Sep 4, 2019
    SFO likes this.
  3. David Scott Dallas

    David Scott Dallas Junior Member

    Joined:
    Oct 15, 2017
    33
    12
    0
    Location:
    Dallas
    Vehicle:
    2015 Prius
    Model:
    One
    I bought a rebuilt one on eBay. The guy I bought it from says I need to check the connection on the fuel inclination meter
     
  4. Skibob

    Skibob Senior Member

    Joined:
    Sep 14, 2018
    2,912
    1,484
    0
    Location:
    Northern California
    Vehicle:
    2006 Prius
    Model:
    N/A
    The last time I can remember someone having a problem with the fuel gage when changing the combo meter it was a solder bridge I think. The person rebuilt it themselves and used a little too much solder somewhere. Try searching for that thread.
     
    David Scott Dallas likes this.
  5. dolj

    dolj Senior Member

    Joined:
    May 14, 2012
    6,575
    3,413
    0
    Location:
    Wellington, New Zealand
    Vehicle:
    2007 Prius
    Model:
    N/A
    Then again, the guy who has experience with this part, just might know a thing or two. There is also at leat one thread here where the inclination meter was not connected properly. Reconnected and no more problems.

    Moral of this story, is the work should have been checked and verified after install and before putting the dash all back together. Yeah, I know, hindsight is a wonderful thing.
     
    Skibob and JC91006 like this.
  6. Texas Hybrid Batteries

    Texas Hybrid Batteries Senior Member

    Joined:
    Sep 7, 2014
    264
    532
    3
    Location:
    Dallas -Fort Worth
    Vehicle:
    2006 Prius
    Model:
    N/A
    When you do the inclination sensor calibration the odometer should change to a string of 6 digits (this is after you press the odo/trip button 3 times and hold). Does that happen?

    Digits 1 and 4 are the status indicators for each of the two sensors. If the car is level and they are properly connected both digits should be zero. A 1 or a 2 indicate that the vehicle isn't level and a 3 indicates an error. This is a good indication that something isn't plugged in.

    upload_2019-9-4_22-30-14.png
     

    Attached Files:

    dolj and Skibob like this.
  7. David Scott Dallas

    David Scott Dallas Junior Member

    Joined:
    Oct 15, 2017
    33
    12
    0
    Location:
    Dallas
    Vehicle:
    2015 Prius
    Model:
    One
    Actually I did check before I put it back together. The gas gauge worked normally for quite a while before the problem started. Even after it started it works normally for 24 hours and then flashes again
     
  8. David Scott Dallas

    David Scott Dallas Junior Member

    Joined:
    Oct 15, 2017
    33
    12
    0
    Location:
    Dallas
    Vehicle:
    2015 Prius
    Model:
    One
    Thanks for the info. Exactly what I was looking for. I did do the recalibration but I was focused on the third digit. That’s what I was told to watch for. I’ll do it again and see.
     
  9. David Scott Dallas

    David Scott Dallas Junior Member

    Joined:
    Oct 15, 2017
    33
    12
    0
    Location:
    Dallas
    Vehicle:
    2015 Prius
    Model:
    One
    0613 are the first four digits. While I was holding the button and it was going back-and-forth between 0613 and 0623 but mainly 0613. Sounds like I know what I’ll be doing tonight. I don’t know about anyone else but taking the dash apart and working on the speedometer seems really easy
     
    Skibob likes this.
  10. David Scott Dallas

    David Scott Dallas Junior Member

    Joined:
    Oct 15, 2017
    33
    12
    0
    Location:
    Dallas
    Vehicle:
    2015 Prius
    Model:
    One
    I live in Carrollton. I added your website to my favorites. If I know anybody that needs a battery I’ll send them to you. I’ll need one eventually. I’ve got 170,000 miles on this car and I drive about 90 to 100,000 miles a year
     
  11. David Scott Dallas

    David Scott Dallas Junior Member

    Joined:
    Oct 15, 2017
    33
    12
    0
    Location:
    Dallas
    Vehicle:
    2015 Prius
    Model:
    One
    The connector for the inclinometer was plugged in but slightly askew. I secured it and all seems well now. Haven’t driven it much since then so maybe it’ll flash again but the gas gauge showed empty before I fixed it and afterwards it was on 2 bars. That’s a good sign I think.
     
    Skibob likes this.
Loading...