Front camera mod problem

Discussion in 'Prius v Audio and Electronics' started by GregPL, Jun 21, 2019.

  1. GregPL

    GregPL New Member

    Joined:
    Jun 21, 2019
    15
    5
    0
    Location:
    Poland
    Vehicle:
    2013 Prius+ MPV
    Model:
    N/A
    Hi!

    I'm new here, so first of all I would like to say hello to everyone :)
    ... and then ask for your help :) (BTW: sorry for my english, but I hope it's "understandable").

    Here is my story:
    I've got 2013 Prius + (MY2014) "all included" version (JBL, active cruise control, Intelligent Park Assist, and so on), and one thing I've missed was front camera, so I've decided to install one.
    First problem I met was, that camera signal is not connected to headunit (JBL GreenEdge B9035), but to IPA ECU, then converted to VGIF and send to headunit. So I've connected two cameras via relay to IPA ECU (L65, pins 15 and 38). Camera signal (front or rear) on IPA ECU input is selected by button. Furthermore: when button is pushed (this selects front camera signal on IPA ECU video input), +12V signal to REV pin of headunit (L38, pin 2) is delivered (also with use of relay).
    Now the problem is: sending +12V to REV on headunit doesn't switch to camera view :( (no matter which camera is selected).
    The only way I can see image from front camera is to set reverse gear and push camera button I've installed (I can choose by button: front camera or rear camera view, and it works... only when "R" gear is selected).
    Any ideas how to force headunit to display camera view? (service mode is not the answer ;) ).

    Regards,
    Greg
     
  2. Leadfoot J. McCoalroller

    Leadfoot J. McCoalroller Senior Member

    Joined:
    May 12, 2018
    3,072
    2,882
    1
    Location:
    Pennsylvania
    Vehicle:
    2018 Prius c
    Model:
    Two
    Have you verified that you've got the right input pin on the head unit? Have you observed it going to +12v when shifting to reverse?

    Any chance the head unit is listening for a CAN signal for gear select?
     
  3. GregPL

    GregPL New Member

    Joined:
    Jun 21, 2019
    15
    5
    0
    Location:
    Poland
    Vehicle:
    2013 Prius+ MPV
    Model:
    N/A
    Yes, input is correct - I've checked everything twice. Pushing camera button sends +12V to REV pin of HU (selecting "R" gear also sends +12V to REV pin)
    I'm affraid, that you might be right about head unit listening to the CAN bus data. Unfortunately my lack of knowledge about CAN won't let me find out if this is responsible for switching display of HU.
     
    #3 GregPL, Jun 22, 2019
    Last edited: Jun 23, 2019
Loading...