Fungus in instrument cluster?

Discussion in 'Gen 3 Prius Main Forum' started by xbdude, Sep 1, 2010.

Thread Status:
Not open for further replies.
  1. xbdude

    xbdude opticat

    Joined:
    Oct 14, 2005
    168
    1
    0
    Location:
    North Central Florida
    Vehicle:
    2010 Prius
    Model:
    III
    Brought my 2010 to the dealer today for it's first oil change (9,650 miles in 11 months). Been noticing some dark areas near the trip display, and also along the hybrid system indicator bar-- it's been getting worse over time. I thought some pixels may be going out, so I brought it to the attention of the service writer. Seems as if a fungus is growing in there. So the dealer will replace whatever is bad, parts will be in tomorrow and the job takes about 4 hours. All covered by warranty. My car never stays outside, and is garaged at night! Anyone heard of this happening?
     
  2. eglmainz

    eglmainz New Member

    Joined:
    Jan 21, 2009
    887
    141
    0
    Location:
    Chicagoland, IL
    Vehicle:
    2010 Prius
    Model:
    V
    Mold?? In Florida?? Stop the presses...

    Seriously though, this is not normal. There must have been something in there which caused the mold to flourish prior to it being sealed at the factory, or something happened to that seal somehow, and air and molds started to flourish.

    I know a friend of mine had a similar thing occur to his Toyota, and he lived in Miami.
     
  3. Paradox

    Paradox Prius Enthusiast / Moderator
    Staff Member

    Joined:
    Sep 22, 2005
    29,111
    8,580
    201
    Location:
    USA
    Vehicle:
    2014 Prius v wagon
    Model:
    Five
  4. mainerinexile

    mainerinexile No longer in exile!

    Joined:
    Mar 14, 2010
    403
    72
    0
    Location:
    Maine
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    Blame climate change.
     
  5. DeanFL

    DeanFL 2010 owner - 1st Prius

    Joined:
    Apr 13, 2009
    1,015
    352
    0
    Location:
    Leesburg Florida USA
    Vehicle:
    2010 Prius
    Model:
    V

    ??? I thought most of us get into a Prius to be green...

    ??? This may be Toyota's alternative to Ford's 'growing leaves' display in their Hybrids...

    I live in the same geo area as you and my car similar age and environment. No issues here.
    Hope they don't need to strip the dash out to gain access...I always worry about post-service effects.

    Good luck, and please report back.
     
  6. FL_Bob

    FL_Bob Junior Member

    Joined:
    Jul 23, 2009
    8
    1
    0
    Location:
    Lake Worth, FL
    Vehicle:
    2010 Prius
    Model:
    III
    Had same problem about a month after delivery - change out the MFD and all has been well since (1 year)
     
  7. xbdude

    xbdude opticat

    Joined:
    Oct 14, 2005
    168
    1
    0
    Location:
    North Central Florida
    Vehicle:
    2010 Prius
    Model:
    III
    The dealer changed my glass today, and all is well . . . . so far! Looked just like the photos posted in the thread link above.
     
  8. BytesDoc

    BytesDoc Junior Member

    Joined:
    Jun 27, 2010
    14
    0
    0
    Location:
    Redondo Beach,CA
    Vehicle:
    2010 Prius
    Model:
    III
    What is MFD?
     
  9. BytesDoc

    BytesDoc Junior Member

    Joined:
    Jun 27, 2010
    14
    0
    0
    Location:
    Redondo Beach,CA
    Vehicle:
    2010 Prius
    Model:
    III
    I have same problem on my Prius III with Nav Package. Went to dealer today. They ordered part. Spoke with shop Mgr about how much of dashboard they would have to remove to fix. According to what he told me they have to remove dashboard, Nav Package and center console. I am apprehensive because every car I ever had that had to have dashboard removed they never re-installed like new, left parts out, did not fit tight, etc. Do you have Nav Pkg also? How much of dash did they have to remove? Where they able to reassemble with all seams tight? Thanks for any info. Mike
     
  10. The Electric Me

    The Electric Me Go Speed Go!

    Joined:
    May 22, 2009
    8,770
    5,377
    0
    Location:
    Undisclosed Location
    Vehicle:
    Other Non-Hybrid
    Model:
    N/A
    Yes, there is at least one other thread where an owner living in a relatively humid location (can't remember where) had fungus growing in his display.

    So if it's any consolation you aren't the only one.

    "This may be Toyota's alternative to Ford's 'growing leaves' display in their Hybrids"-***That's funny thanks for the laugh.
     
  11. BytesDoc

    BytesDoc Junior Member

    Joined:
    Jun 27, 2010
    14
    0
    0
    Location:
    Redondo Beach,CA
    Vehicle:
    2010 Prius
    Model:
    III
    I have Prius III with Nav Pkg but not Solar. Been wanting to talk with someone that has Solar feature. Do you notice much difference with it after parking in direct mid-day sun on 90+ day? When you activate Solar feature does Sun roof tilt up to exhaust hot air? Where does it exhaust hot air to outside? If you are able to email directly please do and I will email you back my phone number. Thanks, Mike
     
  12. Lsegovic

    Lsegovic New Member

    Joined:
    Aug 18, 2010
    78
    4
    0
    Location:
    Florida
    Vehicle:
    2010 Prius
    Model:
    III
    Bytesdoc the solar ventilation work fine, I have forgotten to turn in on when I leave the car in the parking lot and MAN it was brutally hot inside when I came back! I try to turn off the feature in a rainy day to avoid pushing humidity inside the car.

    It's a shame that the solar doesn't cover any of the AC load during driving because places like here in Florida the AC really uses a lot the power saved in the traction battery, my Prius can't work the AC on battery more than a few minutes before the engine quicks in during high traffic or parked.
     
  13. new2hybrid

    new2hybrid New Member

    Joined:
    Dec 16, 2009
    35
    3
    0
    Location:
    Delmarva
    Vehicle:
    2010 Prius
    Model:
    II
    Just had it happen last week over "trip A" where you can't see it. Looks like a fingerprint but when I tried to remove it, realized it was under the glass. I saw previous comments about how they can fix it and remove the dashboard, which I'm hesitant to do to. Was even hard for me to take it in for the first oil change. Did not have one issue prior to this (have had 9 months). This did happen right after my oil change but have no clue how this could be related . .
     
  14. Paradox

    Paradox Prius Enthusiast / Moderator
    Staff Member

    Joined:
    Sep 22, 2005
    29,111
    8,580
    201
    Location:
    USA
    Vehicle:
    2014 Prius v wagon
    Model:
    Five
Loading...
Thread Status:
Not open for further replies.