Gen 2 NON JBL no audio from main speakers, low from tweets

Discussion in 'Gen 2 Prius Audio and Electronics' started by Meter guy, Jan 17, 2021.

  1. Meter guy

    Meter guy Junior Member

    Joined:
    Jan 8, 2013
    17
    2
    0
    Location:
    Florida
    Vehicle:
    2009 Prius
    Model:
    II
    hi guys,

    I did a search before posting and didn't see anything i could identify with.

    so about a month ago, the sound went out on my NON JBL stereo, all 4 main door speakers dont work, but if i crank the volume up to max, i can hear some audio from the 2 front door tweeters.

    went to the junk yard and pulled some non jbl radios, all do the same exact thing, so im thinking there must be something else, it cant be my unit and 4 others have exactly the same problem. if these had such a common issue, i would think it would be plastered all over this forum.

    is there something im missing? this is a plain jane gen 2, nothing fancy.

    while im on the post, I have several gen 2 JBL 6 disc radios too, is there a way to modify a non JBL to have the 6 disc changer from a JBL?

    thanks.
     
  2. sam spade 2

    sam spade 2 Senior Member

    Joined:
    Mar 31, 2018
    4,523
    1,889
    0
    Location:
    USA
    Vehicle:
    2017 Prius c
    Model:
    Four
    The main audio amp may be in a separate box which has failed ?
    Or you have lost the common ground in the speaker wiring ??
     
  3. Meter guy

    Meter guy Junior Member

    Joined:
    Jan 8, 2013
    17
    2
    0
    Location:
    Florida
    Vehicle:
    2009 Prius
    Model:
    II
    from my research, the only separate amp would be the JBL system, located under the passenger seat. i do not have such an amp or anything under either front seats. there is a nice beefy heatsink on the back of the radio, so i would assume it has a basic amp built in.
     
  4. Meter guy

    Meter guy Junior Member

    Joined:
    Jan 8, 2013
    17
    2
    0
    Location:
    Florida
    Vehicle:
    2009 Prius
    Model:
    II
    ok so today i took one of my door panels off, and checked the speaker resistance, the speaker is open, no resistance reading at all, so its bad.
    went to the junk yard today with my multi meter, checked a Prius and 3 RAV4's (same speaker design)
    the Prius had 4 Pioneer aftermarket speakers cobbled into it, all had 3.5 to 4 ohms
    the rav4's were mostly bad too, no reading, open. so im thinking there must be a common problem with these factory speakers failing.

    of the 4 RAV4's I got 4 good speakers out of 10

    i plugged in one of the good speakers into my door and it works fine, so the issue is not the radio.

    hope this thread will help someone in the future :)
     
    PensacolaRevitup and dolj like this.
  5. sam spade 2

    sam spade 2 Senior Member

    Joined:
    Mar 31, 2018
    4,523
    1,889
    0
    Location:
    USA
    Vehicle:
    2017 Prius c
    Model:
    Four
    It would be very unusual indeed for ALL of your speakers to go bad at the same time.
    Please let us know when you get the total problem solved.
     
  6. PensacolaRevitup

    PensacolaRevitup New Member

    Joined:
    May 1, 2020
    4
    0
    0
    Location:
    Pensacola, FL
    Vehicle:
    2009 Prius
    Model:
    N/A
    I have the same issue on my 2009.

    Thinking of replacing the speakers.
     
  7. Meter guy

    Meter guy Junior Member

    Joined:
    Jan 8, 2013
    17
    2
    0
    Location:
    Florida
    Vehicle:
    2009 Prius
    Model:
    II
    I think what has happened, is one speaker failed at a time until the last one died and i really didnt notice until no sound.
     
  8. Meter guy

    Meter guy Junior Member

    Joined:
    Jan 8, 2013
    17
    2
    0
    Location:
    Florida
    Vehicle:
    2009 Prius
    Model:
    II
    pull the connector on the speakers and check for resistance...
    I got averages between 3.5 and 4 ohms on my multimeter

    heres a EASY video for removing the door panel.

     
  9. egg_salad

    egg_salad Active Member

    Joined:
    Oct 27, 2015
    542
    417
    18
    Location:
    Las Vegas, NV
    Vehicle:
    2008 Prius
    Model:
    Base
    I watch a YouTube channel about a car stereo shop in Florida, Clearwater, maybe. It's astounding how many OEM speakers fail in that climate, it seems the two biggest offenders are GM and Toyota.
     
Loading...