Gen 2 Prius weird issues

Discussion in 'Gen 2 Prius Care, Maintenance and Troubleshooting' started by Suede1000, May 16, 2022.

  1. Suede1000

    Suede1000 New Member

    Joined:
    May 16, 2022
    20
    4
    0
    Location:
    New York
    Vehicle:
    2007 Prius
    Model:
    II
    My car turned off while driving (red triangle also) and I could hear a screeching sound while pulling over loud clanks almost like a e brake or something was applied . I’m still not sure brake lights was on too . Once I stopped, I turned the car off and turned it on in like 30 mins and the AC which wasn’t blowing cold that day was cold and the car was working good now without any sounds and drove home … any idea what it could be ? Inverter recently changed 2 months ago and coolant is moving when I check but I got a p1121 code for coolant flow valve control what could that mean ? That’s the only issue I could pull up . To me it sounds like the car over heated and works fine when it’s back .
     
  2. PriusCamper

    PriusCamper Senior Member

    Joined:
    Mar 3, 2012
    8,089
    3,307
    0
    Location:
    Pacific Northwest, USA
    Vehicle:
    2007 Prius
    Model:
    Two
    The noises you described sound horrific... Definitely not the noise of p1121. Any other symptoms? Can you confirm this wasn't road debris?
     
  3. TMR-JWAP

    TMR-JWAP Senior Member

    Joined:
    Aug 12, 2016
    4,977
    5,107
    0
    Location:
    Columbia, SC
    Vehicle:
    2007 Prius
    Model:
    Touring
    Loss of ac is a good sign you need a new inverter cooling water pump. It would be worth checking for flow in the reservoir while the car is in ready mode or IG-ON mode. I have seen these pumps run intermittently prior to a full failure.

    The other possible issue based on the sound could be just the regular engine water pump bearings going out, but I don't know that it would sound as horrible as you're describing. :unsure: The P1121 (coolant control valve sticking) pertains to a 3 way valve at the thermos, but even when it fails, it doesn't typically shut the car off.

    Unfortunately, just guesses. Any chance you know someone with Techstream software that could do a true diagnostic for you?
     
    #3 TMR-JWAP, May 16, 2022
    Last edited: May 16, 2022
  4. Suede1000

    Suede1000 New Member

    Joined:
    May 16, 2022
    20
    4
    0
    Location:
    New York
    Vehicle:
    2007 Prius
    Model:
    II
    My first suspicion was the inverter and I checked for turbulence there is movement. So I’m not too sure what it could be. The car runs and drives fine with no noises , but I’m trying to figure out what that could be. It’s strange because everything is fine. Very strange
     
  5. Suede1000

    Suede1000 New Member

    Joined:
    May 16, 2022
    20
    4
    0
    Location:
    New York
    Vehicle:
    2007 Prius
    Model:
    II
    No road debris lol, but for a moment I’ve had a suspicion something was wrong . The car lately in idle will knock hard when in low battery mode and running on the gas engine ( battery charging mode, while parked ) , but will run and drive fine . I’ve driven the car a few times since the first shutoff , and no weird instances . The AC is cold , but something is wrong and I’m not too sure.
     
  6. ChapmanF

    ChapmanF Senior Member

    Joined:
    Mar 30, 2008
    17,371
    11,794
    0
    Location:
    Indiana, USA
    Vehicle:
    2010 Prius
    Model:
    IV
    Or a phone ... post a recording of the sound.
     
  7. Suede1000

    Suede1000 New Member

    Joined:
    May 16, 2022
    20
    4
    0
    Location:
    New York
    Vehicle:
    2007 Prius
    Model:
    II
    It hasn’t happened since it just happened only once
     
Loading...