Gen 3 2010 Prius Rough, loud idle, knocking

Discussion in 'Gen 3 Prius Care, Maintenance & Troubleshooting' started by chrillermiller, Dec 14, 2019.

Tags:
  1. chrillermiller

    chrillermiller New Member

    Joined:
    Dec 14, 2019
    6
    2
    0
    Location:
    17244
    Vehicle:
    2010 Prius
    Model:
    N/A
    My son has a 2010 Gen 3. Started horribly knocking, shaking a few weeks ago. 225,000 miles. Was showing Generic Missfire codes and missfire on cylinder 1, 3, 4. Check engine light on.

    Took to local shop. They recommended plugs, coils, EGR cooler and valve. $2600.

    We took the car home and have done the following:

    Cleaned EGR cooler.
    Cleaned EGR pipe.
    Replaced EGR valve.
    Replaced Plugs.
    Replaced Coils.
    Replaced PCV valve.
    New MAF sensor.
    Removed and cleaned intake manifold.
    Cleaned throttle body.
    No codes showing as of now.
    Check Engine light will flash when accelerating quickly.


    The engine runs smooth at idle, but hiccups occasionally - feels like it missfires at around 18-23 MPH and 40 - 43 MPH.

    What's next to explore? I'm ready to give up.
     
    Priuslover09 likes this.
  2. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    94,732
    42,957
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    welcome!

    hopefully not the start of a headgasket leak
     
    tankyuong likes this.
  3. dig4dirt

    dig4dirt MoonGlow

    Joined:
    Apr 6, 2012
    1,075
    688
    0
    Location:
    Lancaster Co PA
    Vehicle:
    2014 Prius c
    Model:
    Two
    Mileage is up there
    Lets say no to head gasket :/


    How about the injectors?
    Did u look over all the vacuum lines etc?
     
  4. Grit

    Grit Senior Member

    Joined:
    Aug 22, 2017
    5,302
    3,737
    1
    Location:
    Wilkes Land
    Vehicle:
    2012 Prius
    Model:
    Four
    Are you loosing coolant?
     
    Mendel Leisk likes this.
  5. Mendel Leisk

    Mendel Leisk Sand Pounder

    Joined:
    Oct 17, 2010
    45,529
    32,507
    80
    Location:
    Greater Vancouver, British Columbia, Canada
    Vehicle:
    2010 Prius
    Model:
    Touring
    Try a leak-down test.

    Leaving it to 225K to clean the EGR, and with those symptoms, I'd suspect it is the head gasket. Not the end of the world. If the leak-down test confirms it, replacement is doable.
     
    Radiospank likes this.
  6. chrillermiller

    chrillermiller New Member

    Joined:
    Dec 14, 2019
    6
    2
    0
    Location:
    17244
    Vehicle:
    2010 Prius
    Model:
    N/A
     
  7. chrillermiller

    chrillermiller New Member

    Joined:
    Dec 14, 2019
    6
    2
    0
    Location:
    17244
    Vehicle:
    2010 Prius
    Model:
    N/A

    Forgot to mention that. I did replace injectors.
    Visually inspected lines, and tried to put pump smoke through, but could not see anything.
     
  8. chrillermiller

    chrillermiller New Member

    Joined:
    Dec 14, 2019
    6
    2
    0
    Location:
    17244
    Vehicle:
    2010 Prius
    Model:
    N/A
    Bought the car at 200,000 miles. Not sure if EGR had ever been serviced/cleaned before.
    No done a leak down test. That checks the pressure under the spark plug to check pressure in cylinder?
     
  9. chrillermiller

    chrillermiller New Member

    Joined:
    Dec 14, 2019
    6
    2
    0
    Location:
    17244
    Vehicle:
    2010 Prius
    Model:
    N/A
    We didn't really notice if it was low until yesterday. It was a little low, but no visible signs of recent leak. Have topped off and ran it for a little while yesterday trying to see if losing any coolant now.
     
  10. Mendel Leisk

    Mendel Leisk Sand Pounder

    Joined:
    Oct 17, 2010
    45,529
    32,507
    80
    Location:
    Greater Vancouver, British Columbia, Canada
    Vehicle:
    2010 Prius
    Model:
    Touring
    It uses a special 2-gauge set, applies pressure t cylinders one at a time (via the spark plug hole), with the cylinder at TDC on the compression stroke. The behaviour of the gauges tells things, and just listening at various places, you can tell if there's leakage from the cylinder into some other circuit.

    Google "eric the car guy leak-down test" for a pretty good video, though he has trouble with his (new) gauge set.
     
  11. chrillermiller

    chrillermiller New Member

    Joined:
    Dec 14, 2019
    6
    2
    0
    Location:
    17244
    Vehicle:
    2010 Prius
    Model:
    N/A
    10-4. Will explore looking for testing equipment. In the mean-time...

    Next question:
    I had said earlier that no codes were present. My son drove for a few miles this morning. Check Engine light came on.
    PO304 - Cylinder 4 Misfire - Does any of the recorded data from when the code was triggered tell us anything useful? For example, 1006 RPM. There are other data points - using RPM as example.
     
    TheeWood likes this.
  12. CharlesPrius

    CharlesPrius Member

    Joined:
    Apr 22, 2017
    130
    58
    2
    Location:
    California
    Vehicle:
    2010 Prius
    Model:
    Two
    Mine had similar issues, needed new head gasket. Mech said it's a common problem for 2010. Electric water pump tends to fail on this model and there's no code for that so you just burn coolant without knowing it and one day it blows. I had it fixed and has run well for the past 35k miles. Now it's doing similar thing but i think this time it's the EGR circuit/valve/throttle/maf needs cleaning b/c i'm not losing coolant this time.
     
  13. Neil_onea

    Neil_onea New Member

    Joined:
    Mar 13, 2021
    2
    0
    0
    Location:
    San Francisco
    Vehicle:
    2012 Prius
    Model:
    Four
    Have you tried replacing the engine air filter? That stopped my misfire
     
Loading...