Head unit bluetooth issues

Discussion in 'Gen 1 Prius Plug-in 2012-2015' started by Malmenator, Apr 7, 2020.

  1. Malmenator

    Malmenator Junior Member

    Joined:
    Apr 23, 2018
    4
    0
    0
    Location:
    Los Angeles
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Advanced
    I have a 2012 PIP and all of a sudden the display on my head unit won't show the song title or artist that is playing from my phone and it won't automatically start playing when I start up the car. I also can't use the steering wheel controls to change the track. This all used to function perfectly fine before. I'm not sure if it's something I need to change in the car settings or the phone settings. The car has the JBL option, and my phone is a Galaxy S10+. Help! Thank you!

    Posted via the PriusChat mobile app.
     
  2. QuantumFireball

    QuantumFireball Active Member

    Joined:
    Mar 22, 2016
    333
    199
    0
    Location:
    Ireland
    Vehicle:
    2012 Prius Plug-in
    Bluetooth is always flakey for me, half the time it doesn't display the track details, and occasionally doesn't want to connect unless I turn off/on the head unit. I haven't seen the problem with changing the tracks though - except for the occasions where the head unit doesn't want to work at all (e.g. even volume control doesn't work) and the only solution is to restart the whole car! It's not a great experience in general.
     
  3. Nick Seifert

    Nick Seifert New Member

    Joined:
    Sep 1, 2019
    9
    3
    0
    Location:
    Vermont
    Vehicle:
    2012 Prius Plug-in
    Model:
    Five
    Is it a new phone? or has that feature worked with it before? It might be worth seeing if you received an update to your phone recently. You might also try un-pairing from the head unit, delete the paring from your phone, then re-pair it.
     
  4. Montgomery

    Montgomery Senior Member

    Joined:
    Sep 11, 2015
    1,670
    1,716
    2
    Location:
    Orange County, CA
    Vehicle:
    2015 Prius
    Model:
    Two
    I agree with Nick. Re-pair up. See what happens. Also, if anyone else drove your car and paired up, it really messes things up. Even if you are sitting in your driveway and the other person is in the house and haven't disconnected.
     
  5. art425

    art425 New Member

    Joined:
    Jan 10, 2020
    4
    1
    0
    Location:
    California
    Vehicle:
    2014 Prius Plug-in
    Model:
    Plug-in Base
    I was also having issues like you, title won't show and bluetooth won't connect sometimes. What seemed to have fixed it for me was doing an entune firmware update. Can be downloaded online, although there are some risks to doing a firmware update, I bricked my router from a failed firmware update lol.
     
Loading...