Heater only heats while driving (ICE off when stopped)

Discussion in 'Gen 2 Prius Care, Maintenance and Troubleshooting' started by audiodane, Jan 20, 2020.

  1. audiodane

    audiodane Junior Member

    Joined:
    Aug 1, 2013
    2
    0
    0
    Vehicle:
    2007 Prius
    Model:
    N/A
    Hey folks;

    I have a 2007 Prius.. Recently replaced the dash indicator capacitors (yay!).. Now I'm moving to the next problem; I tried to search but my situation doesn't seem to match other threads. My apologies if this has been solved and I just couldn't find it among all the other threads.

    The heater is only providing hot air while driving. When sitting at a stop light, even when requesting 85F air on a 35F ambient day. Blower comes on just fine, and as I mentioned, as I start driving, I can feel the temperature of the air coming out of the blower getting warmer. Come to a stop at the next traffic light for a few minutes, the ICE turns off (instead of usually staying on because I'm asking for hot air), and I can feel the air temperature coming out of the blower slowly dropping. Once I start moving again, ICE comes back on, and air starts to get warmer again.

    It seems to be some sort of sensor must have gone bad and the system doesn't know when it needs to keep the ICE running. But that's about where my knowledge of cars stops!

    Any advice on how to diagnose this would be appreciated. It's probably not worth trying to take to a repair shop, but if it's something I could try to do myself (like the dash indicator capacitor fix), that would be ideal.

    cheers,
    ..dane
     
  2. JC91006

    JC91006 Senior Member

    Joined:
    Nov 10, 2013
    14,109
    6,818
    0
    Location:
    Los Angeles, CA
    Vehicle:
    2010 Prius
    Model:
    V
    1. check that you have enough coolant in your radiator and there is no air in the system (bleed it).
    2. if the radiator is full and no air is in the system, then you'll probably need to replace the servo motor that controls the heat controls inside the cabin. Since it's electronic, that can freeze up and you won't get hot air (or cold air)
     
  3. valde3

    valde3 Senior Member

    Joined:
    Jun 28, 2014
    1,788
    609
    0
    Location:
    Finland
    Vehicle:
    2004 Prius
    If you turn the temperature to max does this still happen? If yes check that it's not air or blockage in cooling system. If not those it has to be related to heater core elecric water pump or power going to it.
     
  4. RobertK

    RobertK Member

    Joined:
    Sep 9, 2007
    106
    29
    0
    Location:
    Norfolk, VA
    Vehicle:
    2007 Prius
    Model:
    N/A
    This sounds like the supplemental electric heater pump is not working. You get heat when the engine is running because the engine water pump is supplying hot water to the heater core. The ICE will start if the water cools down enough, but that shouldn't happen when the engine is warmed up.
     
    mindogas likes this.
  5. Frank1234

    Frank1234 Junior Member

    Joined:
    Jan 18, 2020
    32
    17
    0
    Location:
    Ohio
    Vehicle:
    2001 Prius
    Model:
    ----USA----
    I think this is a simple fix, you just need a new thermostat!
     
    #5 Frank1234, Jan 21, 2020
    Last edited by a moderator: Jan 22, 2020
  6. dolj

    dolj Senior Member

    Joined:
    May 14, 2012
    3,967
    2,097
    0
    Location:
    Wellington, New Zealand
    Vehicle:
    2006 Prius
    valde3 and RobertK's advice is probably more on the money.
     
    M in KC likes this.
Loading...