HELP! ABS pump went out Prius V

Discussion in 'Prius v Care, Maintenance and Troubleshooting' started by erick vazquez aguirre, Mar 1, 2019.

  1. erick vazquez aguirre

    Joined:
    Jan 25, 2019
    6
    0
    0
    Location:
    Venice, FL
    Vehicle:
    2012 Prius v wagon
    Model:
    Five
    Hey guys i got a Prius V , the Abs pump went out , still able to brake but my dash is all lit up and the pump beeps every 3 seconds. Dealer wants $2000 for the repair $1400 for brake assembly and $600 for labor , they dont sell just the pump you have to buy whole assembly i guess. I am very mechanically inclined and was wondering if i can replace this pump myself if got a used one like on ebay or would i need to have techstream for some reason to activate the pump or bleed the brakes? Thank you
     
  2. Air_Boss

    Air_Boss Senior Member

    Joined:
    Jun 2, 2012
    2,579
    542
    0
    Location:
    New Yawk
    Vehicle:
    2012 Prius v wagon
    Model:
    Five
    Starting to see more of these.... Not good.

    How many miles and (initial pressurization) start-up cycles?
     
    #2 Air_Boss, Mar 1, 2019
    Last edited: Mar 1, 2019
  3. erick vazquez aguirre

    Joined:
    Jan 25, 2019
    6
    0
    0
    Location:
    Venice, FL
    Vehicle:
    2012 Prius v wagon
    Model:
    Five
    115,000 miles, my abs is gone . Can i buy another used pump and swap it ? or would i need to bleed brakes , activate it with some speciual software . Made a complaint to the NHTSA and also to toyota
     
  4. tankyuong

    tankyuong Active Member

    Joined:
    Nov 9, 2012
    880
    322
    0
    Location:
    Central MO
    Vehicle:
    2010 Prius
    Model:
    III
    Tech stream necessary
     
  5. erick vazquez aguirre

    Joined:
    Jan 25, 2019
    6
    0
    0
    Location:
    Venice, FL
    Vehicle:
    2012 Prius v wagon
    Model:
    Five
    techstream necessary for what , to activate it ?
     
  6. tankyuong

    tankyuong Active Member

    Joined:
    Nov 9, 2012
    880
    322
    0
    Location:
    Central MO
    Vehicle:
    2010 Prius
    Model:
    III
    Yo cycle the pump
     
Loading...