Help Prius headache. Red triangle of death

Discussion in 'Gen 2 Prius Care, Maintenance and Troubleshooting' started by Bamendaboy, Nov 30, 2019.

  1. Bamendaboy

    Bamendaboy New Member

    Joined:
    Nov 30, 2019
    3
    0
    0
    Location:
    Mn
    Vehicle:
    2009 Prius
    Model:
    N/A
    Hey everyone. Newbie here. Hope I am on the right forum.
    I need help.
    I have the red triangle of death on my dash board and car won't go into drive or reverse or inspection mode.

    Here is what I did originally.
    I am currently located in Minnesota.
    Car has had no heat for a while now.
    Scan code threw the code P1121 or so, and was pointing to the invertor water pump underneath the drivers side headlight. Did my research and stumbled on this video here


    Everything pointed to it being the auxiliary water pump because I had changed the other 2 coolant pump behind the heat lights.

    I followed the instructions on how to change it.
    Disconnected the 12 battery. ( Battery lost charge when I was done so had to go recharge it at Orrieleys).

    Unplugged the cables that go into the battery underneath the hood, replaced the auxiliary water pump and put everything back accordingly. When I try to start it and put it on inspection mode so I could bless the system,
    It won't go into inspection mode.

    There is the red triangle of death that is there permanently when the car is on.
    It can only go into neutral and park.
    Any ideas how to fix this? Been on it all day and it is cold as hell :-(

    Thanks in advance
     
  2. TMR-JWAP

    TMR-JWAP Senior Member

    Joined:
    Aug 12, 2016
    3,464
    3,927
    0
    Location:
    Columbia, SC
    Vehicle:
    2007 Prius
    Model:
    Touring
    This is all over the place and confusing.

    P1121 is a failure of the 3 way control valve and has nothing to do with the inverter cooling water pump.

    Here's a guide for troubleshooting a P1121

    I'm also confused about what battery wires you disconnected.

    Did you do anything with the orange safety disconnect for the HV battery?
     

    Attached Files:

    jerrymildred likes this.
  3. Bamendaboy

    Bamendaboy New Member

    Joined:
    Nov 30, 2019
    3
    0
    0
    Location:
    Mn
    Vehicle:
    2009 Prius
    Model:
    N/A
    Thanks mate. The P1121 was for an earlier work I did replacing the inverter coolant pump. Now I remember. Now for the job I did( replaced the Auxilary coolant pump by drivers side firewall) Apparently, I think I was supposed to disconnect the the orange safety disconnect switch on the HV battery but I failed to do so. I was able to pull out the code p080D. Bought a new 12 V battery thinking that that was the problem and when I came, this evening to work on it, the new battery too had already drained. Do i need to replace the orange switch where you disconnect from the HV battery? Is there a fuse there that has blown or something? Thanks for your response.
     
Loading...