Hybrid battery error codes P0AFA, P0AC0, P3000-123, C1310

Discussion in 'Gen 2 Prius Care, Maintenance and Troubleshooting' started by shre, Sep 25, 2020.

  1. shre

    shre New Member

    Joined:
    Aug 16, 2020
    5
    1
    0
    Location:
    Illinois
    Vehicle:
    2008 Prius
    Model:
    II
    Hello all,
    My first post here & I apologize its a bit long. My Gen 2 prius (158K miles) has several codes and poor fuel economy (33 highway). Hope to get insights from y'all on the diagnosis and possible next steps.
    On a recent long road trip it was raining for the most part. The following codes showed up during the return journey and have stayed solid since then.
    Codes: P0AFA, P0AC0, P0016, P3000-123, ABS: C1310, C1241, C1259, C1378

    I used techstream to try diagnosing issues. Here is what I did so far:
    - Old 12V Battery swapped with a brand new compatible battery (DieHard Platinum AGM) after the road trip
    -Sealed the hairline cracks near the trunk door trim and there is no more moisture inside the car trunk. The 12V battery well and other places are dry.
    - Cleaned corrosion off the copper terminals and nuts (Salt+Vinegar and baking soda) and reinstalled them.
    - There was little corrosion on 2 terminals of the orange connector to the hybrid battery ECU. Cleaned all terminals of the plug and the battery ECU connector. Cleaned visible corrosion on the inside of the battery ECU terminals.
    - Cleaned and checked all wires running from hybrid battery to ECU using a multimeter and saw no issues with connectivity.
    - Checked all car fuses and they are okay. I know of the orange disconnect for the HV and I make sure to 'push it down'.
    A possibly relavant problem: After a recent car wash, the 12V battery discharged to 11.6V (from car's dashboard display). Person at Advanced Auto checked the voltage after disconnecting battery from car and it was >12.1V. Voltage went up to 13.8V after ignition on. Since the wash the pickup of the car from a stop has noticably become really slow.
    Techstream shows that HV battery modules 2 and 3 often fluctuate between 16 and -15.84 V. All other modules stay around 16.2V. I haven't run a load test on individual modules (don't have the right equipment)
    I cleared trouble codes using TechStream but they still reappeared.

    I would like pointers for diagnosing these issues and possible next steps
    - The 12V battery issue indicates a short somewhere that got worse with the car wash. Where are possible points check that?
    - I am planning to disassemble the hybrid battery and change the 2 cells with fluctuating voltages. What else can I check while I am in there? Could there be another source of problem other than the cells?
    - Do you think it is a problem with the hybrid ECU?
    - Does any of this have something to do with the P0016 error? Suggestions on checking on it?

    Thanks,
     
    #1 shre, Sep 25, 2020
    Last edited: Sep 25, 2020
  2. Hersh

    Hersh Junior Member

    Joined:
    Sep 16, 2019
    1
    0
    0
    Location:
    Charlotte NC
    Vehicle:
    2012 Prius
    Model:
    Three
    Hi. I have a 2008 Prius with similar codes i dumped using bluedriver. I would like to get the techstream software and a cable to dig in to the hybrid battery pack. Where can I purchase a Techstream kit that works for a good price?
     
  3. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    89,778
    40,242
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
  4. dolj

    dolj Senior Member

    Joined:
    May 14, 2012
    4,846
    2,620
    0
    Location:
    Wellington, New Zealand
    Vehicle:
    2006 Prius
    Get a VxDiag from their website. They are better than the cheap MVCI and comparatively still good value for money compared to purchasing the 'approved' Drew Technologies cable.
     
Loading...