Inverter/inverter pump

Discussion in 'Gen 3 Prius Care, Maintenance & Troubleshooting' started by Sb859, Apr 30, 2021.

  1. Sb859

    Sb859 New Member

    Joined:
    Apr 30, 2021
    3
    0
    0
    Location:
    Ny
    Vehicle:
    2015 Prius
    Model:
    Two
    I just bought a 2015 Prius from a private seller (which I will never do again!)..some idiot put the wrong fluid into the inverter. It's throwing codes P0A93 and C1300 It's been at my local Toyota dealership for 3 weeks now. They've flushed it 3 times- didn't fix the issue, then they said the inverter would have to be replaced, they took it for a test drive and now not only did the triangle and exclamation point and check engine come back on for the same hybrid issue but also they said driving it a highway speeds felt like they were driving on gravel (hoping it's just the wheels need to be balanced).. now I'm up to a $3500 bill and the issue is still present and now it's bumpy at higher speeds.. I asked the service advisor if they had switched the inverter out or if they switched the pump inverter out .. they said they switched the inverter not the pump... if it's throwing codes for the pump why didn't they try replacing the pump ??? Was it necessary for them to switch the inverter out first??.. I'm beyond stressed at this point! Need some clarification on this. I'm seriously thinking this shop doesn't know what they are doing, might have to buy the part and go rogue on this one as they are putting me in a hole with debt. Anybody have some insight on this?
     
  2. tankyuong

    tankyuong Senior Member

    Joined:
    Nov 9, 2012
    1,299
    565
    0
    Location:
    Central MO
    Vehicle:
    2010 Prius
    Model:
    III
    Need second opinion
     
  3. ChapmanF

    ChapmanF Senior Member

    Joined:
    Mar 30, 2008
    12,028
    8,726
    0
    Location:
    Indiana, USA
    Vehicle:
    2010 Prius
    Model:
    IV
    What was it? Do they know?
     
  4. Grit

    Grit Senior Member

    Joined:
    Aug 22, 2017
    4,689
    3,443
    1
    Location:
    Wilkes Land
    Vehicle:
    2012 Prius
    Model:
    Four
    should we mention egr circuit cleaning, or wait after all is said and done?
     
  5. ChapmanF

    ChapmanF Senior Member

    Joined:
    Mar 30, 2008
    12,028
    8,726
    0
    Location:
    Indiana, USA
    Vehicle:
    2010 Prius
    Model:
    IV
    I would say wait, unless you're thinking it's just easier to do with the inverter out.
     
  6. Sb859

    Sb859 New Member

    Joined:
    Apr 30, 2021
    3
    0
    0
    Location:
    Ny
    Vehicle:
    2015 Prius
    Model:
    Two
    They said it was supposed to be the type of coolant with a pinkish color, not the yellow kind. Whoever worked on this car prior must not have known..
     
  7. Sb859

    Sb859 New Member

    Joined:
    Apr 30, 2021
    3
    0
    0
    Location:
    Ny
    Vehicle:
    2015 Prius
    Model:
    Two
    the codes read inverter pump just like before they had started working on it.. after they had replaced the actual inverter now they are finally saying the inverter pump needs to be replaced.. we went ahead and ordered the part from Rock Auto and will be replacing it ourselves.. as the dealership is way too expensive.(100% markup and labor is straight up outrageous!) Hoping the pump being replaced will fix the trouble code and I can get this inspected and finally on the road.
     
  8. Grit

    Grit Senior Member

    Joined:
    Aug 22, 2017
    4,689
    3,443
    1
    Location:
    Wilkes Land
    Vehicle:
    2012 Prius
    Model:
    Four
    :ROFLMAO:
     
Loading...