MFD not getting battery/engine/inverter or ac info

Discussion in 'Gen 2 Prius Audio and Electronics' started by PtotheRius, Aug 28, 2017.

Tags:
  1. PtotheRius

    PtotheRius Junior Member

    Joined:
    Aug 20, 2017
    7
    5
    0
    Location:
    Florida
    Vehicle:
    2007 Prius
    Model:
    N/A
    Hi everybody,
    So today I took my 2007 Prius to get an aftermarket stereo installed. The technician kept the car on the whole time and did not disconnect the battery or anything. After the install, the red triangle came on and the MFD stopped displaying any info from either the AC or the inverter/engine/battery. I was initiaƱly concerned that the tech had shorted something by not turning the car off, but the car runs well, AC works, switches from battery to engine, and after turning it off and back on, the red triangle disappeared. I went home and plugged in my OBD2 reader and there's no engine codes or anything. My best guess is that the tech disconnected whatever connections sends the AC and battery/engine/inverter info to the MFD. Has anyone had something like this happen before? Is there something else I should test before taking it back to the shop? Any help or advice much appreciated. I am in Miami. Thanks!
     
  2. marquis1366

    marquis1366 New Member

    Joined:
    Apr 10, 2020
    2
    0
    0
    Location:
    houston tx
    Vehicle:
    2006 Prius
    Model:
    N/A
    did you get any answers on this issue? im having this same issue now
     
  3. Umerpk

    Umerpk Junior Member

    Joined:
    Aug 25, 2018
    16
    2
    0
    Location:
    Pakistan
    Vehicle:
    2006 Prius
    Model:
    N/A
    Install a 68ohm resistor and everything will start to work except voice recognition and IPA (if your car is equipped). Some after market stereos do not support the special CAN functionality of AC and MFD display of mileage. You will get everything back ON. Install a resistor... Enjoy

    Posted via the PriusChat mobile app.
     
  4. dolj

    dolj Senior Member

    Joined:
    May 14, 2012
    4,327
    2,309
    0
    Location:
    Wellington, New Zealand
    Vehicle:
    2006 Prius
    An aftermarket stereo should not affect the ability of the MFD to display those, except if an inadequate interface harness or steering wheel control (SWC) harness has been used.
     
Loading...