Mystery issue with brake lights

Discussion in 'Gen 2 Prius Care, Maintenance and Troubleshooting' started by Kristen678, Aug 19, 2020.

  1. Kristen678

    Kristen678 New Member

    Joined:
    Aug 6, 2020
    14
    5
    0
    Location:
    Denver, CO
    Vehicle:
    2006 Prius
    Model:
    N/A
    Hi all -
    About a month or so ago, I received a series of warning lights (Parking Brake, ABS, and Traction Control) immediately after an oil change and an attempt by a mechanic to reset the warning light for the TPMS. Because I didn't know if this somehow happened during the oil change, I bought a code reader (VEEPEAK) and used the Garage Pro app. The code that came up is C1249, Open in Stop Light Switch Circuit. The warning lights rarely come on but the code is always the same.

    In researching the code, there were a few options for the cause such as the brake lamp switch, wiring, cruise control brake release issue, speed sensor.

    The cruise control did get wonky when this initially happened. Cruise control was activated, but not in use when the light started blinking. When I tried to reengage the cruise control, it wouldn't work until I'd turned the car off then on again.

    Today, I learned that when the brakes are engaged, only the brake light on the hatchback comes on - the other two do not. This is regardless of whether or not the warning lights are on. When I remove my foot from the brake pedal, the light goes back off (I mention that because I read that the lamp switch failure could make them stay on all the time).

    Does anyone know what is happening here?
    Thanks in advance!!
    Kristen
     
  2. valde3

    valde3 Senior Member

    Joined:
    Jun 28, 2014
    1,982
    725
    0
    Location:
    Finland
    Vehicle:
    2004 Prius
    Seems like there's something wrong with brake lights or wiring. You don't have a tow hitch in you're car? Or some other modification to tail light wiring? If yes check those connections first. If no mayby check for bad brake lights first.
     
  3. sam spade 2

    sam spade 2 Senior Member

    Joined:
    Mar 31, 2018
    3,886
    1,702
    0
    Location:
    USA
    Vehicle:
    2017 Prius c
    Model:
    Four
    Do the tail lights.....in the same assembly.....work when you turn the headlights ON ?
    The classic most common cause of a problem like this was a loose ground wire serving the stop lights.
    But I don't know if they depend on frame ground like they used to.
     
  4. Kristen678

    Kristen678 New Member

    Joined:
    Aug 6, 2020
    14
    5
    0
    Location:
    Denver, CO
    Vehicle:
    2006 Prius
    Model:
    N/A
    No tow hitch or other modifications. :/
     
  5. Kristen678

    Kristen678 New Member

    Joined:
    Aug 6, 2020
    14
    5
    0
    Location:
    Denver, CO
    Vehicle:
    2006 Prius
    Model:
    N/A
    Sam Spade - Yes! When the headlights are on, they light up.

    Is it possible that the wiring problem is happening in the area under the driver's side dash? After the oil change, the rep kept emphasizing how hard the mechanic tried to reset the TPMS (it's busted on the tire). The warning lights came on the same day.
     
  6. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    89,719
    40,196
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    check the 12v neg to ground
     
  7. rjparker

    rjparker Senior Member

    Joined:
    Jun 6, 2008
    2,199
    935
    1
    Location:
    Texas Hill Country
    Vehicle:
    2012 Prius v wagon
    Model:
    Three
    I would check the BN Ground point in the back and the connectors at the lights
    29AE4E6E-AA29-4FAD-9D6E-4B6B84104EB5.jpeg CCFE2CF3-9851-444B-91FE-EC7614F3DD77.jpeg
     
    Kristen678 and valde3 like this.
  8. dolj

    dolj Senior Member

    Joined:
    May 14, 2012
    4,826
    2,612
    0
    Location:
    Wellington, New Zealand
    Vehicle:
    2006 Prius
    Starting multiple threads on the same problem is not a good idea. Choose one of your threads to move forward on and link the other threads back to them, or ask a moderator to combine the threads.
     
  9. Kristen678

    Kristen678 New Member

    Joined:
    Aug 6, 2020
    14
    5
    0
    Location:
    Denver, CO
    Vehicle:
    2006 Prius
    Model:
    N/A
  10. Johnphoenix

    Johnphoenix New Member

    Joined:
    Sep 13, 2020
    11
    0
    0
    Location:
    Phoenix
    Vehicle:
    2007 Prius
    Model:
    One
    My brake lights do work. So i am not doing anything yet.
    My mechanic says if abs turns on and generally stays on and if you get either c1256 or c1391 then we should replace brake actuator.

    my abs,vsc,! indicator turned on and went away 3-4 times and the code has been c1246. My mechanic just cleared the code.

    my actuator makes that noise every 20 sec(while not driving) and every 10 sec while driving.
     
    #10 Johnphoenix, Sep 18, 2020
    Last edited by a moderator: Sep 19, 2020
  11. SFO

    SFO Senior Member

    Joined:
    Feb 7, 2017
    3,191
    3,296
    0
    Location:
    Northern California
    Vehicle:
    2007 Prius
    Model:
    N/A
    Here is the workup for DTC C1246 : https://share.qclt.com/%E4%B8%B0%E7%94%B0%E6%99%AE%E7%91%9E%E6%96%AF%E5%8E%9F%E5%8E%82%E8%8B%B1%E6%96%87%E6%89%8B%E5%86%8Cpdf%E6%A0%BC%E5%BC%8F/repair%20manual/04pruisr/05/21avn/cic12464.pdf

    Notice in the above workup for DTC C1246 that there are eleven (11) possible 'detailed codes' (aka sub codes or INFs), knowing the INF for a DTC may save time and money when diagnosing or repairing a problem.

    Does the mechanic have a toyota hybrid compatible scanner that can provide the sub code(s) (detailed code or INF) for DTC C1246 ?
     
    Raytheeagle likes this.
  12. Johnphoenix

    Johnphoenix New Member

    Joined:
    Sep 13, 2020
    11
    0
    0
    Location:
    Phoenix
    Vehicle:
    2007 Prius
    Model:
    One
    Sorry. I mistyped. My code has always been c1249 not c1246. It has been checked 2 times now after clearing. But every time the abs, vsc,(!), Brake indicator comes on and goes away after i stop. It comes on again at random usually in the next drive or the one after. The frequency of indicators coming on has increased. In the last 2 months i have had it come on a total of 8 times. But in the last 7 days it has come on 3-4 times. Since c1249 seems non-critical (just a abs feature that i hardly would use in a dry desert) i am not taking any action. The brake lights work like a charm.
    Would you do anything different ?
     
Loading...