Need advise. Abs,brake light, and check engine lights on..

Discussion in 'Gen 2 Prius Care, Maintenance and Troubleshooting' started by Zkolbes, May 23, 2017.

  1. Zkolbes

    Zkolbes Junior Member

    Joined:
    May 23, 2017
    14
    3
    0
    Location:
    Michigan
    Vehicle:
    2006 Prius
    Model:
    N/A
    So i have a 2006 prius with just under 125k on it. I have been driving with lights on for a week or two. I stopped in to autozone a week ago and they pulled the code p1121 ans said coolant control valve.
    Heres the issue most of my problems im getting is with the brakes. Sometimes when i turn the car on and put in to gear whether its drive or reverse it just rolls into gear and have to reapply the brakes.

    Now there is a long beep when i open the car door and or when i start. At that time the brake pedal is super stiff. Yesterday this happened while driving on the highway and lasted longer than the normal 10 seconds. I got off the next exit with a stiff nice person pedal. Was a little scary.

    So ive done research for hours and i think (from what i looked up) that its the abs booster. So i decided to take it to the dealership and all they came back with is the damn p1121 code and says its my coolant control valve.

    Just dont see how im getting such bad brake problems,the beep, forgot to mention the clicking/running sound after i turn off or while sitting when the cars on. (Sounds like its trying to charge the system?)

    Please let me know if u have any advise to what to do. Cant afford to fix both as the ccv is 600 and the abs pump is 2000 plus
     
  2. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    88,714
    39,649
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    check the health of your 12 volt as well.
     
  3. Zkolbes

    Zkolbes Junior Member

    Joined:
    May 23, 2017
    14
    3
    0
    Location:
    Michigan
    Vehicle:
    2006 Prius
    Model:
    N/A
    Thanks forgot to mention that. It was reading 11.8
     
  4. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    88,714
    39,649
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    with everything off, that would be bad.
     
  5. Zkolbes

    Zkolbes Junior Member

    Joined:
    May 23, 2017
    14
    3
    0
    Location:
    Michigan
    Vehicle:
    2006 Prius
    Model:
    N/A
  6. Mendel Leisk

    Mendel Leisk Senior Member

    Joined:
    Oct 17, 2010
    40,121
    28,664
    80
    Location:
    Greater Vancouver, British Columbia, Canada
    Vehicle:
    2010 Prius
    Model:
    Touring
    upload_2017-5-23_9-42-38.png
    Low battery may well not be the source of all your problems, but it's good first step, something easily addressed, "low hanging fruit".
     
    Raytheeagle likes this.
  7. Zkolbes

    Zkolbes Junior Member

    Joined:
    May 23, 2017
    14
    3
    0
    Location:
    Michigan
    Vehicle:
    2006 Prius
    Model:
    N/A
    When not in ready mode it reads 11.8
    When i turn it on and in ready mode it reads 14.1
     
  8. Mendel Leisk

    Mendel Leisk Senior Member

    Joined:
    Oct 17, 2010
    40,121
    28,664
    80
    Location:
    Greater Vancouver, British Columbia, Canada
    Vehicle:
    2010 Prius
    Model:
    Touring
    Your first reading is the one that matters.
     
  9. Zkolbes

    Zkolbes Junior Member

    Joined:
    May 23, 2017
    14
    3
    0
    Location:
    Michigan
    Vehicle:
    2006 Prius
    Model:
    N/A
    So would you recommend changing that. Then what. Clear the codes and see what happens within a day or two.
     
  10. Zkolbes

    Zkolbes Junior Member

    Joined:
    May 23, 2017
    14
    3
    0
    Location:
    Michigan
    Vehicle:
    2006 Prius
    Model:
    N/A
    Seems as if i have more than one problem..?
     
Loading...