Need help.....P0A7A...

Discussion in 'Gen 2 Prius Care, Maintenance and Troubleshooting' started by Noahlr, Sep 3, 2018.

  1. Noahlr

    Noahlr New Member

    Joined:
    Sep 1, 2018
    11
    1
    0
    Location:
    Iowa
    Vehicle:
    2008 Prius
    Model:
    ----USA----
    2008 with 113000 miles

    DTC P0A7A...all dash warning lights are on

    lost all acceleration while driving

    it will start for a few seconds then stall

    replaced with good parts
    Inverter
    HV ECU
    12v battery

    inverter coolant pump is functioning as it should...

    Any ideas before i take it to the dealer?

    i like to do my own repairs and maintenance whenever possible...
    we have had nothing but bad experiences at our local dealer.

    please if you have any ideas or suggestions i would greatly appreciate it...

    thanks Noah
     
  2. Paul Schenck

    Paul Schenck Active Member

    Joined:
    Jun 15, 2013
    466
    243
    0
    Location:
    Fresno, California
    Vehicle:
    2005 Prius
    Model:
    II
    It means your Electronic Control Module (ECM) Is sensing a short from the Inverter.
    (Thanks for stating the obvious right?)
    Since you had someone replace the inverter, there is a good chance the problem is a Loose connection right?
    So disconnect your battery take out the orange plug and Check them all.
    I just swapped mine and posted a time lapse so you can see that and use it and a manual to check all your connections. When you’ve check this you keep your eyes out for anything that looks shorted and check fuses related to the inverter.
    There is a good chance it’s a loose connection and since the ECM wasn’t getting the information it needed its shutting things down.


    iPhone ?
     
    Noahlr likes this.
  3. Noahlr

    Noahlr New Member

    Joined:
    Sep 1, 2018
    11
    1
    0
    Location:
    Iowa
    Vehicle:
    2008 Prius
    Model:
    ----USA----
    Thanks for the reply...

    I checked all wiring connections and fuses hoping that's what the issue was before I changed out the inverter and then the hv ecu. Any chance the inverter pump could be causing this even though its currently working? What fuses are tied to the inverter?
     
  4. Paul Schenck

    Paul Schenck Active Member

    Joined:
    Jun 15, 2013
    466
    243
    0
    Location:
    Fresno, California
    Vehicle:
    2005 Prius
    Model:
    II
    49
    Toyota Prius (XW20; 2008 - 2009) - fuse box diagram - Auto Genius


    iPhone ?
     
    Noahlr likes this.
  5. Noahlr

    Noahlr New Member

    Joined:
    Sep 1, 2018
    11
    1
    0
    Location:
    Iowa
    Vehicle:
    2008 Prius
    Model:
    ----USA----
  6. Patrick Wong

    Patrick Wong DIY Enthusiast

    Joined:
    Mar 8, 2008
    18,156
    6,206
    0
    Location:
    Green Valley, AZ
    Vehicle:
    2015 Prius
    Model:
    Two
    I think you should get the repair manual info at techinfo.Toyota.com and follow the trouble shooting for DTC P0A7A. You have already replaced the two likely failed components so you now need to look for a failed wiring connection.
     
    Paul Schenck, Noahlr and strawbrad like this.
  7. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    90,908
    40,841
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    why did you start a new thread?
     
  8. Noahlr

    Noahlr New Member

    Joined:
    Sep 1, 2018
    11
    1
    0
    Location:
    Iowa
    Vehicle:
    2008 Prius
    Model:
    ----USA----
    I'm new to the site and posted in the main form....I didn't see the specific categories. Figured more people who were mechanically inclined would be in this category.
     
    bisco likes this.
Loading...