Newby With Prius, (Gotta Fix It Myself)

Discussion in 'Newbie Forum' started by Transit, Aug 13, 2019 at 7:27 AM.

  1. Transit

    Transit New Member

    Joined:
    Aug 9, 2019
    3
    0
    0
    Location:
    Australia
    Vehicle:
    2006 Prius
    Model:
    Excel
    YESTERDAYS POST 12Th August

    So I'm asking the brethren, for some help, please ?
    Here is the history;
    1) 2006 gen 2 , bog standard version, blue in color, fairly good condition, paid $3.000.00 for the unit.
    second day of driving it, threw a code C1256,C1310, UO293 along with some lost communication code , triangle of death, limp mode etc etc .
    2)Short version, with basic electronics background, i pulled the main battery and followed this Russian guys blog, on U-Tube who lives in US. He was extremely thorough. His ID on U-Tube is Igor Kadulenkov. So I followed the battery reconditioning to the letter, then some, I have 4 full battery packs at my disposal. Anyhow we got through it had taken a couple of intensive weeks. I drew 3-4 batteries from the donor packs as mentioned and changed out the faulty ones, balanced the pack and put it back into service.
    So, it didn't work. Laugh Out Loud !
    3) Moving on, I had taken note that some of the time, when I received the triangle of death, along with engine light, battery fan running, and the brake icon (I Think,)
    4) Next I changed both front brake sensors (ABS) didn't fix problem.
    5) So my next plan is to change my Hybrid Water Pump, Then I will put a set of new spark plugs into the engine. I am fully aware this wont fix the problem.
    6) So the next major brainstorm, is to change the main Hybrid Unit under the bonnet engine bay (Inverter/Convertor Unit) which involves inverter cooling system bleed. I will go right over the vehicle disconnecting, cleaning and reconnecting electrical plugs (This Car is Not going To Beat Me) I got ripped off buying it, now I'm hopefully going to fix it .
    So begging and cringing , I ask all of the prius experts to please throw their hat into the ring, throw some ideas around.
    I HOPE ITS NOT THE ABS UNIT , that job looks scary. Please bare in mind, this Prius drives perfectly , sometimes it goes for two weeks before it starts the games. ABS functions perfectly , Ive tested it on loose surface. But I have 3 things, which are the following;
    1)Throws the faults on hitting a bump sometimes.
    2)Seems do it when screaming along at 100ks. Up until now, it usually didn't do it at low speeds. But now its starting to throw these codes at low speeds. It did it the other night while cruising slowly through a car parking station, on battery only. And It starting to do it, when going into the fault codes, using my Bosch general purpose scan tool, 200 hundred dollar unit (Generic)
    So this has been plaguing me for three months, slowly getting worse. If I am forced to take it to Toyota, the battles lost. )))))

    I thank you in anticipation.

    TODAY 13TH AUGUST

    #1 Transit, Yesterday at 8:23 PM
    So I'm attempting getting used to this great, chat forum . However it wont let me post a formal (Reply To You Guys,) something about me not being part of the forum for long enough and the number of posts, which Ive uploaded. (No Idea ? But Soon Enough It Will Become Clear I Expect)
    So based on the info you guys released to me, I didn't want to mess anybody around, so I went and looked up a friend who has a pirate copy of Techstream. (Well I'm Guessing This)
    So we plugged in the laptop and he had hassles, with talking to the Toyota but he managed to extract the codes through Techstream, one code at a time. He may have some hassle with the OBD2 reader, I don't know ?
    Anyhow, we got some info , please see the following :-
    U0121 -Lost Communication with Anti-Lock Brake System (ABS) Control Module.
    U0293-Lost Communication with Hybrid Vehicle Control System
    POA80- Replace Hybrid Battery Pack
    So the last code is disheartening, considering the amount of work that was put into the job, reconditioning the pack. Maybe we did something wrong or maybe the packs are just too old ? Anyhow it is what it is !
    So with your experiences, is it as simple as install a brand new battery pack ? Done Deal Fixed, No More Hassles ? OR IS THEIR OBVIOUSLY MORE TO THIS ? OR IS IT , IF THE PACK IS CACTUS, OR SIMPLY A MODULE CACTUS ? Do these other problems occur ?
    No Matter What , I intend To whether The Storm And Stick To These Little Gems, Eventually The Penny Will Drop And I Should Get Some Understanding Over Time, Together With Experience , In turn I Can Help People.
    Thanks Again
    Regards Transit
     
    #1 Transit, Aug 13, 2019 at 7:27 AM
    Last edited: Aug 13, 2019 at 7:33 AM
  2. PriusCamper

    PriusCamper Senior Member

    Joined:
    Mar 3, 2012
    2,532
    867
    0
    Location:
    Pacific Northwest, USA
    Vehicle:
    2007 Prius
    Model:
    Two
    Don't worry about the High voltage battery pack yet... That error code needs to be checked after the other codes are resolved... Basically the main computer has lost communication with peripheral computers.

    The fact that it's both ABS computer and the HV battery computer makes me think the problem is with your main computer... Ideally, if you have access to a replacement you could swap it out to see if that's the problem. And while swapping it out inspect the wiring harness and plugs for signs of damage or corrosion.
     
    Transit likes this.
  3. Transit

    Transit New Member

    Joined:
    Aug 9, 2019
    3
    0
    0
    Location:
    Australia
    Vehicle:
    2006 Prius
    Model:
    Excel
    Much Thank You, Pruis Camper, I Have A "Dona" Prius To Draw Parts From. Its An 03 or 04.
    Just one other question. Ive noticed on Gen2 Prius early versions have slightly different instrument head up, I think the fuel gauge is located into a slightly different layout. Which makes me a little concerned if required . When needing say ? A main hybrid unit (Under The Bonnet, High Tension Unit) Remove and replace into the later model ? So in other words if needed can I take the Inverter/Converter from the 03-04, reinstalling into my 06 ? And last, where is the main computer located in my vehicle ?
    Thank You
    Transit
     
  4. PriusCamper

    PriusCamper Senior Member

    Joined:
    Mar 3, 2012
    2,532
    867
    0
    Location:
    Pacific Northwest, USA
    Vehicle:
    2007 Prius
    Model:
    Two
    Don't have experience with that so hard to answer your questions... But if you start searching online for spare parts you'll eventually establish if your '04 parts car's computer is compatible with your '06. Usually the main ECU is mounted under the dashboard.

    Perhaps someone with experience with this will chime in?
     
  5. prius_deep

    prius_deep Member

    Joined:
    Apr 2, 2017
    80
    29
    0
    Location:
    road
    Vehicle:
    2016 Prius
    Model:
    Two
    ? have you checked the motor oil level ?
     
Loading...