P010A and triangle of death

Discussion in 'Gen 2 Prius Care, Maintenance and Troubleshooting' started by AskSergeantWagner, Jan 1, 2019.

  1. AskSergeantWagner

    AskSergeantWagner Junior Member

    Joined:
    Jan 10, 2013
    5
    3
    0
    Location:
    Tallahassee, Florida
    Vehicle:
    2006 Prius
    Model:
    Three
    Howdy folks. I've got an '06 with 190k miles on it. Today she gave me P010A, red triangle of death, and wouldn't run. I cleared the code and she's running fine so far but I thought I'd pick your collective brains. I'm thinking of cleaning some of the air intake components and maybe changing the intake manifold gasket because it's cheap. I'm moderately worried that the MAF sensor is slowly dieing of old age and will have to be replaced but I didn't want to jump the gun on a $70 part, especially if it doesn't come back. Are there any tests I can do to see what might have triggered the code?
     
  2. SFO

    SFO Senior Member

    Joined:
    Feb 7, 2017
    2,693
    2,902
    0
    Location:
    Northern California
    Vehicle:
    2007 Prius
    Model:
    N/A
    Not sure if you meant to post in the Gen2 forum, otherwise 'Report' your post and ask for it to be moved to the proper Gen3 forum.

    Which ODB2 device are you using to read the DTCs with?

    It may not be reading all of the codes, or the detail sub codes (INFs).

    Find a can of MAF cleaner and try cleaning the sensor, will only take a few minutes.
     
    Raytheeagle likes this.
  3. AskSergeantWagner

    AskSergeantWagner Junior Member

    Joined:
    Jan 10, 2013
    5
    3
    0
    Location:
    Tallahassee, Florida
    Vehicle:
    2006 Prius
    Model:
    Three
    I thought the 2006 was a gen 2. I used to have a 2010 as well but we sold that one. The issue hasn't returned since I last posted but I cleaned the MAF sensor and throttle body today. The MAF sensor was completely black and I'm surprised I wasn't still having issues. The odbii scanner I used was a Bluetooth one from Amazon, I've tried a few different apps with varying success. Overall I've been pretty happy with it. I mostly posted because I don't know if the MAF sensor should be swapped out after so many miles or if it should outlast the rest of the car. Getting the triangle of death spooked me a bit, I'm used to being able to limp home if I had to and not being able to run the car has me worried I'll get stuck somewhere. I feel pretty good after seeing how dirty it was but does anyone know how long the MAF sensor should last?

    Edit: I saw that my profile still showed 2010 Prius, I've corrected it.
     
    bisco likes this.
  4. Matthew Lindsay

    Matthew Lindsay New Member

    Joined:
    Jul 23, 2019
    15
    3
    0
    Location:
    Harrisburg, Pennsylvania
    Vehicle:
    2007 Prius
    Model:
    II
    Grr....having the same problem. 2007 with 175k. Just had the hybrid battery replaced. Two weeks after that I get P010A and Triangle. Cleaned the MAF sensor and throttle body. Change engine air filter. So freaking easy BTW. Why a shop charges $250 for a 20 minute job that requires almost no knowledge and no tools...

    Mileage is fine 53 MPG average. No noticeable issues. I got it to run with no problem for 19 cycles...I thought I had fixed the issue. But it came back and comes on almost immediately...

    I ordered a replacement MAF sensor...who knows...
     
  5. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    87,562
    38,973
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    have you read the codes?
     
  6. dolj

    dolj Senior Member

    Joined:
    May 14, 2012
    4,344
    2,324
    0
    Location:
    Wellington, New Zealand
    Vehicle:
    2006 Prius
    P010A is not a valid Gen 2 DTC. With what are you reading the DTCs?
     
  7. Matthew Lindsay

    Matthew Lindsay New Member

    Joined:
    Jul 23, 2019
    15
    3
    0
    Location:
    Harrisburg, Pennsylvania
    Vehicle:
    2007 Prius
    Model:
    II
    Yeah. realized the cheap reader isn't going to help. Pointed me in all the wrong directions... however It did get me to do some needed maintenance things (throttle body cleaning, air filter, sensor cleaning, new spark plugs). I ordered a techstream kit. Im sure it has something to do with the hybrid battery. I re-seated the orange safety thinger on the side of the traction battery. My Prius randomly goes into triangle/disabled mode. It drove for a week with no problems then triangle and disable came back on again. Now it wont go 2 miles without it popping on. i'm fairly certain it's not something catastrophic...but i'm a risk taker....
     
  8. Mileage_Mofo

    Mileage_Mofo New Member

    Joined:
    Apr 22, 2019
    16
    3
    0
    Location:
    92114
    Vehicle:
    2005 Prius
    Model:
    II
    I'm having the same issue today, going 30mph for one mile, red triangle and loss of horsepower. Pulled off the road and read codes with an older Bluetooth OBDll -P010A and P0111.
    Sat for an hour and then drive 2 miles fine, no warning lights.
     

    Attached Files:

  9. dolj

    dolj Senior Member

    Joined:
    May 14, 2012
    4,344
    2,324
    0
    Location:
    Wellington, New Zealand
    Vehicle:
    2006 Prius
    You need a better scanner, one with the correct PIDs loaded so that it can read Gen 2 Prius correctly. Neither of those two codes are valid Gen 2 Prius codes.

    And rather than tacking onto and hijacking another person's thread, start your own thread with the codes when you have them. It is highly unlikely you have exactly the same issue.

    In addition, discussing several faults (cars) in the same thread can make it very hard to keep track of what information belongs where. In keeping problems separate, it helps us to help you.
     
    #9 dolj, Aug 16, 2019
    Last edited: Aug 17, 2019
    Matthew Lindsay and SFO like this.
  10. Mileage_Mofo

    Mileage_Mofo New Member

    Joined:
    Apr 22, 2019
    16
    3
    0
    Location:
    92114
    Vehicle:
    2005 Prius
    Model:
    II
    Ah dang, sorry about that
     
Loading...