P0304, and no cause found

Discussion in 'Gen 3 Prius Care, Maintenance & Troubleshooting' started by douglasjre, Jan 27, 2019.

  1. douglasjre

    douglasjre Active Member

    Joined:
    Sep 13, 2008
    484
    202
    0
    Location:
    Orlando, FL
    Vehicle:
    2010 Prius
    Model:
    ----USA----
    The engine shutters at 1500 RPMs there's no check engine light lighting up but techstream software reveals a p0304 code. As we know this is a cylinder 4 misfire moving the coil pack from 4 to 3 and the plug from 4 to 2 and the injector from 4 to 1 clearing the codes and retesting it is still reveals the cylinder four misfire and it only happens at 1500 RPMs when the engine is warm not cold. Any knownknown causes? Cylinder compression test 175 PSI for all four cylinders. There is no antifreeze losas andthere'sno oil on the spark plug. And no there isn't any oil in the antifreeze either
     
  2. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    86,293
    38,189
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    ouch. 2010 with how many miles?
     
  3. mjoo

    mjoo Senior Member

    Joined:
    Nov 9, 2016
    895
    1,110
    12
    Location:
    Michigan
    Vehicle:
    2010 Prius
    Model:
    III
    Too much carbon in the combustion chamber? EGR distribution problem (intake manifold EGR ports plugged)?

    Pixel XL ?
     
    m.wynn and Raytheeagle like this.
  4. Raytheeagle

    Raytheeagle Senior Member

    Joined:
    Jul 1, 2016
    9,807
    13,331
    0
    Location:
    Bay Area, California
    Vehicle:
    2019 Prius Prime
    Model:
    Prime Plus
    It’s either fuel or air caused;).

    So if you’ve moved coils around and it still resides in cylinder 4, I’d look at the injector and intake manifold.

    Good luck and keep us posted (y).
     
    mjoo and m.wynn like this.
  5. douglasjre

    douglasjre Active Member

    Joined:
    Sep 13, 2008
    484
    202
    0
    Location:
    Orlando, FL
    Vehicle:
    2010 Prius
    Model:
    ----USA----
    Screenshots
     

    Attached Files:

  6. mjoo

    mjoo Senior Member

    Joined:
    Nov 9, 2016
    895
    1,110
    12
    Location:
    Michigan
    Vehicle:
    2010 Prius
    Model:
    III
    Battery voltage is listed as 12.1V. Isn't that low?

    Pixel XL ?
     
Loading...