P1121 causes and cures

Discussion in 'Gen 2 Prius Technical Discussion' started by ruggb, Dec 2, 2019 at 6:30 PM.

  1. ruggb

    ruggb Junior Member

    Joined:
    Jan 4, 2007
    52
    5
    0
    Location:
    Cary, NC, USA
    Vehicle:
    2007 Prius
    Model:
    N/A
    I replaced the water valve 6 months ago and finally got all the air out. Had a P1121 code then also.
    I have a P1121 code again = along with a few others that do not seem to be related. My FFD indicates that the "tank outlet temperature" is 113 and does not change each time I redo the tests. I have done cold and hot tests. The coolant temp appears to get to ~180°F fairly fast from cold (40-50°F). What it should be relative to the coolant temperature. I exercised water valve #3 and hear it running. I do not hear 4 or 5 when I turn them on.
    Questions:
    1. Is the "Tank" referred to = the thermos?
    2. If so does a constant 113 indicate a problem with the sensor?
    3. Would a problem with the sensor trigger a P1121, all other things being nominal?
    3. Where can I find a verbose description of "tank outlet temperature", "water valve #3", "water valve #4", water valve #5", etc.
     
  2. SFO

    SFO Senior Member

    Joined:
    Feb 7, 2017
    1,904
    2,149
    0
    Location:
    Northern California
    Vehicle:
    2007 Prius
    Model:
    N/A
    In the workup below, it says "If any other codes besides P1121 are output, perform troubleshooting for those DTCs first."

    Here is the workup for DTC P1121 : https://share.qclt.com/%E4%B8%B0%E7%94%B0%E6%99%AE%E7%91%9E%E6%96%AF%E5%8E%9F%E5%8E%82%E8%8B%B1%E6%96%87%E6%89%8B%E5%86%8Cpdf%E6%A0%BC%E5%BC%8F/Repair%20Manual/04pruisr/05/2054m/cip1121a.pdf

    Yes, the tank is also known as coolant heat storage (CHS) tank.

    It does sound like the sensor could be acting up.
     
    Raytheeagle and davecook89t like this.
  3. ruggb

    ruggb Junior Member

    Joined:
    Jan 4, 2007
    52
    5
    0
    Location:
    Cary, NC, USA
    Vehicle:
    2007 Prius
    Model:
    N/A
    Yeah, been there saw that, have it saved on my 'puter.. I think I have read every post on 5 sites related to P1121. Everything seems to keep changing. I reset all the DTCs (I think) and I am waiting for another round. The C1242 is a mystery. I reset some relays and swapped a couple. I can't understand how the IG2 has an open connection if the car starts and runs fine = since that is a direct line to the injectors. The other codes seem to be related to IG2 also. If I get 113 for a tank temp again, it has to be that sensor, right? Though I think there is actually another code (maybe P1116) specifically for that, but I have never seen that. Maybe that is just for open or short. I should get a tank temp close to the cooler temp, correct? I don't know what failure mode would yield 113.
    Is there a way to run the valve with Techstream? There are 3 valves (3, 4, 5), but I have no idea what they are for.
     
  4. SFO

    SFO Senior Member

    Joined:
    Feb 7, 2017
    1,904
    2,149
    0
    Location:
    Northern California
    Vehicle:
    2007 Prius
    Model:
    N/A
    Resetting the DTCs before accurately recording them for future prosperity may not be that helpful.

    Please record and post any known DTCs here. If you currently have just the P1121, then follow the appropriate workup. If you've been following said workup, how far through the process did you make it before reaching "replace" or "NG" ?
    Enter the following menus: Powertrain / Engine and ECT / Active Test / Activate the Water Flow Valve

    edit: spelling
     
    #4 SFO, Dec 3, 2019 at 1:56 AM
    Last edited: Dec 3, 2019 at 11:55 AM
  5. ruggb

    ruggb Junior Member

    Joined:
    Jan 4, 2007
    52
    5
    0
    Location:
    Cary, NC, USA
    Vehicle:
    2007 Prius
    Model:
    N/A
    I do have multiple printed pages and saved files.
    Here is my files.
    I have activated all 3 water flow valves. I can hear #3 when I do it. But have no idea about #4 or #5. Do they actually exist? What/where are they? HOWEVER, after I activate them, I have no idea how to observe the results, like temp changes, etc. So it is a little difficult to run through the workup. But I am also chasing C1242. The reason I reset everything is because it seemed like every time I looked at it, things changed for no apparent reason.

    I would like to find a tutorial on how to use TS as it is still mostly a mystery to me. Even saving results doesn't work for me most of the time.
    thanks for your help
     

    Attached Files:

  6. ruggb

    ruggb Junior Member

    Joined:
    Jan 4, 2007
    52
    5
    0
    Location:
    Cary, NC, USA
    Vehicle:
    2007 Prius
    Model:
    N/A
    New scan. This only showed up as a P1121. The others are known. No C1242.
    tank temp is 55. Sounds like the valve isn't working, but that is really low, like about ambient.
    What do you think.
     

    Attached Files:

  7. SFO

    SFO Senior Member

    Joined:
    Feb 7, 2017
    1,904
    2,149
    0
    Location:
    Northern California
    Vehicle:
    2007 Prius
    Model:
    N/A
    If you can, first work on DTC C1242 if that is the only other code currently logged. Here is the workup for C1242, it has two (2) associated INFs (subcodes), knowing which one can potentially help diagnose the problem quicker (use techstream to find the INF, subcode or 'detailed code') : https://share.qclt.com/%E4%B8%B0%E7%94%B0%E6%99%AE%E7%91%9E%E6%96%AF%E5%8E%9F%E5%8E%82%E8%8B%B1%E6%96%87%E6%89%8B%E5%86%8Cpdf%E6%A0%BC%E5%BC%8F/Repair%20Manual/04pruisr/05/21avn/cic12414.pdf

    On page 451, step 2(g) : The workup for DTC P1121 is : "Measure the voltage between terminals WBAD and E2 of the ECM connector", were you able to obtain the referenced (approximate) voltages for the three (3) valve settings listed?

    On page 451, step 3 (right below the above step) for P1121 : Mentions checking for blockages in the coolant system?

    Which part of the workup for P1121 are you stuck at? [example: page 452, step 3(c)]
     
  8. ruggb

    ruggb Junior Member

    Joined:
    Jan 4, 2007
    52
    5
    0
    Location:
    Cary, NC, USA
    Vehicle:
    2007 Prius
    Model:
    N/A
    I just did that TS test. C1242 did not show this time, so I am not trying to work that now.
    Maybe it needs more time to come back.
    Maybe because I swapped those 2 relays out.

    I have no idea how to access the connectors on the ECM. I assume it is the one located behind the glove box.
    I have no Idea, other than draining the coolant and taking the system apart, how to check for blockage.

    I just saw something that indicated that the 3 water valves listed #3, #4, #5, on the detail DTC are the same unit, just different positions.
    If so, what does turning them on/off do? Is it a step function or is it separate?

    Does that scan tell you anything?
    Why is the coolant temp so low?
    What position is the valve in if the voltage shows 4.5V? == workup indicates it is #5 at that voltage. Does that mean it is trying to connect to the tank?
    If that is correct, then the valve isn't working or there is a clog.
    Previously, when I turned #3 on/off I heard it operate. I heard nothing when I turned #4, or #5 on/off.
     
  9. dolj

    dolj Senior Member

    Joined:
    May 14, 2012
    3,720
    1,930
    0
    Location:
    Wellington, New Zealand
    Vehicle:
    2006 Prius
    So maybe the valve is broken and you need to replace it. Does the work up for P1121 not cover testing that the valve is working? I know one of them does. May look at the P1116.
     
Loading...