P314A info code 828 Inverter Coolant Pump Speed Signal

Discussion in 'Gen 3 Prius Main Forum' started by UK Hybrid, Jan 19, 2019.

  1. UK Hybrid

    UK Hybrid Junior Member

    Joined:
    Oct 7, 2017
    1
    1
    0
    Location:
    UK
    Vehicle:
    2012 Prius
    Model:
    ----UK----
    Hi Guys I need help to sort this problem I already changed the Inverter, Inverter Pump, Power management ECU and IGCT No 3 Fuse. But there is no luck still getting same code P314A Inverter Cooling Pump Speed signal. After clearing the fault codes as soon I start the car all the warning lights goes off and radiator fan start running loudly.
     
    amos likes this.
  2. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    82,237
    35,720
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    is there movement in the fluid?
     
  3. Chuba

    Chuba New Member

    Joined:
    Aug 18, 2019
    10
    0
    0
    Location:
    Nigeria
    Vehicle:
    2012 Prius
    Model:
    Two
    I have this the same issue. There is movement in the fluid
     
  4. BZzap!

    BZzap! Senior Member

    Joined:
    Jun 13, 2012
    1,404
    706
    0
    Vehicle:
    2012 Prius
    Model:
    Two
    At this point, you almost need a Techstream or a scan tool with bi-directional capabilities. Time to bite the bullet...needs a diagnostic inspection. About the only thing you can do without the necessary equipment, is to check all your connectors at the ECM and at the coolant pump harness.
    3 thing that will cause this code:
    1 Bad coolant pump
    2 Bad ECU
    3 Bad or corroded wiring harness
    Good luck
     
  5. Chuba

    Chuba New Member

    Joined:
    Aug 18, 2019
    10
    0
    0
    Location:
    Nigeria
    Vehicle:
    2012 Prius
    Model:
    Two
    Thanks for your response.

    I noticed that my inverter coolant pump is not runing very fast and I recently changed it.
     
Loading...