P3190-Poor engine power and P0A0F-Engine failed to start

Discussion in 'Gen 2 Prius Care, Maintenance and Troubleshooting' started by Stealth1776, Sep 22, 2022.

  1. Stealth1776

    Stealth1776 New Member

    Joined:
    Sep 22, 2022
    1
    0
    0
    Location:
    Kentucky
    Vehicle:
    2006 Prius
    Model:
    N/A
    Working on a 2006 Prius. Keep getting these codes intermittently. One day drives perfect 46 mpg. The next engine turns over 15 seconds but doesn’t start. Sometimes if attempting to drive battery drains and red triangle comes on among other lights and will not drive unless codes are cleared. Did manage to keep it running while spraying brake clean through throttle body. Has rebuilt battery, new fuel tank assembly, clean MAF and throttle body. New with these cars and any help is appreciated.
     
  2. SFO

    SFO Senior Member

    Joined:
    Feb 7, 2017
    4,934
    4,120
    0
    Location:
    Northern California
    Vehicle:
    2007 Prius
    Model:
    N/A
    Welcome to PruisChat!!
    Sounds like you could have a fuel related issue.

    Do you have the needed workups for for the posted OBD2 codes (aka DTCs).

    FYI : you're moderated until you've posted 5 times.
     
  3. Tombukt2

    Tombukt2 Senior Member

    Joined:
    Nov 29, 2020
    3,337
    582
    0
    Location:
    Durham NC
    Vehicle:
    2009 Prius
    Model:
    Base
    Fuel pump possibly . Is gas getting to rail at efi pressures ?
     
    #3 Tombukt2, Sep 23, 2022
    Last edited: Sep 23, 2022
Loading...