P3191 P3190

Discussion in 'Gen 2 Prius Technical Discussion' started by 88gta88, Sep 6, 2019.

  1. 88gta88

    88gta88 Junior Member

    Joined:
    Jul 10, 2017
    4
    4
    0
    Location:
    Nebraska
    Vehicle:
    2005 Prius
    Model:
    ----USA----
    Alright guys. Got a 2007 Prius that will not run for more than 10 seconds and then throws either a P3191 or a P3190. Battery voltage is good at 12.6V, verified that vehicle has spark, fuel volume, fuel pressure is 50 psi, injector pulse is fine. Have cleaned throttle body and mass air flow. Can keep vehicle running with carb cleaner. Kind of running out of ideas if anybody out there has any
    Thanks
     
  2. SFO

    SFO Senior Member

    Joined:
    Feb 7, 2017
    4,865
    4,095
    0
    Location:
    Northern California
    Vehicle:
    2007 Prius
    Model:
    N/A
  3. ChapmanF

    ChapmanF Senior Member

    Joined:
    Mar 30, 2008
    18,802
    12,575
    0
    Location:
    Indiana, USA
    Vehicle:
    2010 Prius
    Model:
    IV
    Have you cleaned the injectors? Being able to keep it running using carb cleaner would seem to suggest you've got compression and spark all right (something is igniting the carb cleaner!), but it doesn't look good for fuel (since that's what your carb cleaner is replacing). If you've verified the fuel pressure arriving at the injectors, and you've verified the drive pulses arriving at the injectors, then it seems like you're closing in on an answer.
     
    strawbrad likes this.
  4. 88gta88

    88gta88 Junior Member

    Joined:
    Jul 10, 2017
    4
    4
    0
    Location:
    Nebraska
    Vehicle:
    2005 Prius
    Model:
    ----USA----
    I’m actually leaning towards the fuel being the problem. The fuel sample I took seems odd and doesn’t burn like the straight gasoline I have for the mower. Think I’ll be pumping the tank today and start with fresh fuel.
     
  5. Raytheeagle

    Raytheeagle Senior Member

    Joined:
    Jul 1, 2016
    11,250
    15,435
    0
    Location:
    Bay Area, California
    Vehicle:
    2019 Prius Prime
    Model:
    Prime Plus
    Have you checked / cleaned the MAF sensor and throttle body?
     
  6. 88gta88

    88gta88 Junior Member

    Joined:
    Jul 10, 2017
    4
    4
    0
    Location:
    Nebraska
    Vehicle:
    2005 Prius
    Model:
    ----USA----
    Got it figured out. I believe the fuel in the tank actually contained some diesel fuel. Drained tank, purged lines, and added fresh gas. Runs like a champ now.
     
    Skibob, Raytheeagle and SFO like this.
  7. Skibob

    Skibob Senior Member

    Joined:
    Sep 14, 2018
    2,909
    1,482
    0
    Location:
    Northern California
    Vehicle:
    2006 Prius
    Model:
    N/A
    Did you just buy this car?
     
Loading...