1. TwoPriusInTenn

    Joined:
    Nov 27, 2015
    141
    44
    0
    Location:
    Florida
    Vehicle:
    2004 Prius
    Model:
    Base
    2010 - 278,000 miles.

    Rough idle at start up then evens out. Replaced spark plugs with oem.

    Here is what TechStream says...
     

    Attached Files:

  2. tankyuong

    tankyuong Senior Member

    Joined:
    Nov 9, 2012
    1,366
    598
    0
    Location:
    Central MO
    Vehicle:
    2012 Prius c
    Model:
    II
    Egr circuit needs to be cleaned
     
    RMB, TwoPriusInTenn and mjoo like this.
  3. TwoPriusInTenn

    Joined:
    Nov 27, 2015
    141
    44
    0
    Location:
    Florida
    Vehicle:
    2004 Prius
    Model:
    Base
    Thank you. Cleaned the EGR and the cooler today. Running better!!
     
    Mendel Leisk, RMB and Raytheeagle like this.
  4. Raytheeagle

    Raytheeagle Senior Member

    Joined:
    Jul 1, 2016
    11,137
    15,246
    0
    Location:
    Bay Area, California
    Vehicle:
    2019 Prius Prime
    Model:
    Prime Plus
    You get the intake manifold too:whistle:?

    Glad it worked out so far(y).
     
    RMB, TwoPriusInTenn and mjoo like this.
  5. TwoPriusInTenn

    Joined:
    Nov 27, 2015
    141
    44
    0
    Location:
    Florida
    Vehicle:
    2004 Prius
    Model:
    Base
    Thank you. Intake manifold, throttle body and egr pipe cleaned as well. Yeah, I've been busy!!!!
     
    Robert Holt, RMB and Raytheeagle like this.
  6. TwoPriusInTenn

    Joined:
    Nov 27, 2015
    141
    44
    0
    Location:
    Florida
    Vehicle:
    2004 Prius
    Model:
    Base
    PO302 2010.jpg PO304 2010.jpg Saga continues PO300, PO302, PO304 - I have cleaned egr, egr cooler, pipe, and intake manifold. Changed all four plugs and coils. Still throwing these three code. I'm thinking it's an injector issue. Here is what TechStream says
     
  7. Raytheeagle

    Raytheeagle Senior Member

    Joined:
    Jul 1, 2016
    11,137
    15,246
    0
    Location:
    Bay Area, California
    Vehicle:
    2019 Prius Prime
    Model:
    Prime Plus
    Engine coolant level is stable?
     
    Grit likes this.
  8. TwoPriusInTenn

    Joined:
    Nov 27, 2015
    141
    44
    0
    Location:
    Florida
    Vehicle:
    2004 Prius
    Model:
    Base
    I have been having to add some as needed lately.
     
  9. Raytheeagle

    Raytheeagle Senior Member

    Joined:
    Jul 1, 2016
    11,137
    15,246
    0
    Location:
    Bay Area, California
    Vehicle:
    2019 Prius Prime
    Model:
    Prime Plus
    Sounds like the head gasket is compromised if the coolant is not on the ground ;).

    You could pull the spark plugs and endoscope them. I bet you’ll find one of them looks wet:cool:.

    Good luck and keep us posted (y).
     
    Grit and Pseudonymm like this.
  10. Pseudonymm

    Pseudonymm New Member

    Joined:
    Jul 31, 2019
    28
    18
    0
    Location:
    The great northeast
    Vehicle:
    2010 Prius
    Model:
    N/A
    What do the Techstream headers -3,-2,-1,0,1 mean? Some sort of chronology, I guess?

    I love the endoscope idea.

    Has there ever even been a documented case where fuel injectors -have- been the issue?
     
  11. Grit

    Grit Senior Member

    Joined:
    Aug 22, 2017
    5,302
    3,732
    1
    Location:
    Wilkes Land
    Vehicle:
    2012 Prius
    Model:
    Four
    Fuel injector being the reason why coolant loss? o_O
     
    Raytheeagle likes this.
  12. mjoo

    mjoo Senior Member

    Joined:
    Nov 9, 2016
    1,041
    1,265
    12
    Location:
    Michigan
    Vehicle:
    2010 Prius
    Model:
    III
    That's a good run for this engine.

    Check out Danlatu's thread. He reused the engine with close to 300k miles
     
    #12 mjoo, Aug 20, 2019
    Last edited: Aug 20, 2019
    Raytheeagle likes this.
  13. Pseudonymm

    Pseudonymm New Member

    Joined:
    Jul 31, 2019
    28
    18
    0
    Location:
    The great northeast
    Vehicle:
    2010 Prius
    Model:
    N/A
    Fuel injector being the reason for misfires/engine trouble. It seems like they're often replaced/messed with as a last resort in a chain of simpler, less expensive repairs for engine trouble, when you ought to just be checking the cylinders for coolant.
     
  14. Raytheeagle

    Raytheeagle Senior Member

    Joined:
    Jul 1, 2016
    11,137
    15,246
    0
    Location:
    Bay Area, California
    Vehicle:
    2019 Prius Prime
    Model:
    Prime Plus
    I’d swap coils before injectors ;).

    Since they are on top of the spark plug, the heavy lifting is done for access :).

    That’s what usually is swapped around and the injectors are usually left in place (y).
     
  15. Dxta

    Dxta Senior Member

    Joined:
    Nov 7, 2016
    1,890
    746
    0
    Location:
    Lagos
    Vehicle:
    2008 Prius
    Model:
    II
    I was trying to decipher what the -3, -2, -1, 0, on tech stream as shown on your scan?
     
  16. TwoPriusInTenn

    Joined:
    Nov 27, 2015
    141
    44
    0
    Location:
    Florida
    Vehicle:
    2004 Prius
    Model:
    Base
    The spark plugs were the first thing I replaced and then all four coils. The injectors are on order and the next to replace. If the injectors don't do the trick, I'll be looking to replace the head gasket.
     
  17. The Critic

    The Critic Resident Critic

    Joined:
    Oct 28, 2005
    3,130
    2,230
    0
    Location:
    CA
    Vehicle:
    2011 Prius
    Model:
    Three
    I suggest doing more diag instead of unleashing the parts cannon.
     
    RMB, Raytheeagle and TwoPriusInTenn like this.
  18. 2011Prii

    2011Prii Junior Member

    Joined:
    Aug 20, 2019
    16
    36
    0
    Location:
    Indianapolis
    Vehicle:
    2011 Prius
    Model:
    One
    I don't know for sure, but I was wondering if that was the freeze frame data and time before (-3, -2, -1 second), during (0 sec), and after (1 sec) the code is triggered. I could be completely off though.
     
  19. TwoPriusInTenn

    Joined:
    Nov 27, 2015
    141
    44
    0
    Location:
    Florida
    Vehicle:
    2004 Prius
    Model:
    Base
    Took off the intake manifold this evening. The carbon residue in cylinder 2 was wet when I put my finger in.

    Symptom of a blown head gasket? Haven't taken out the plugs yet.
     
  20. The Critic

    The Critic Resident Critic

    Joined:
    Oct 28, 2005
    3,130
    2,230
    0
    Location:
    CA
    Vehicle:
    2011 Prius
    Model:
    Three
    Not necessarily.
     
    Raytheeagle likes this.