Poor Gas Mileage, HV battery drain, Whirring noise, Sluggish acceleration

Discussion in 'Gen 2 Prius Main Forum' started by AshokTexas, May 10, 2022.

  1. AshokTexas

    AshokTexas Junior Member

    Joined:
    May 8, 2022
    36
    3
    0
    Location:
    Texas
    Vehicle:
    2008 Prius
    Model:
    III
    Hello all hopefully someone can help me diagnose. I got multiple problems I think or one problem that is the root cause of all others. My vehicle is a 2008 Prius.

    1. I get a constant whirring noise from engine compartment while driving, while stopped with car on or engine turned off, the noise is there. It happens very frequently. A video of noise is posted by a different user here, "Whirring Noise Every 15-30 Seconds?"

    2. Red exclamation triangle flickers for couple of seconds and goes, I have Veepak OBDII reader and Dr.Prius full version and no Codes to read.

    3. Sluggish acceleration, this is my second Prius owned and is a daily driver, so it is not me being used to them. I notice that HV battery goes down all the way to one or two bars. My gas mileage dropped from 44 to 37mpg, same tires in both measurements, same work route.

    4. My HV battery never gets to good charge no matter how hard I try, max I seen lately is 5 out of 8 bars on dash. And in a matter of seconds the charge levels change from 2 bars to 5-6 bars on the dash and vice versa.

    About 6months ago I cleaned the Mass Air Flow Sensor with Air flow sensor cleaner when I got an error code P0101 and cleared the code. I have a OBDII bluetooth reader, Veepak & Dr.Prius app (full version). I do not get any error codes when I read and when I test battery using the app it shows up as good. I do think my 1. is draining battery while parked. Plus when my dash battery shows 2 bars you would expect engine to charge it, but the display shows it is still draining the battery even under no acceleration or throttle, flat ground as well. I even turned AC off and drove and similar behavior on sluggishness.

    Some posts point to a bad 12v battery make Prius do weird things but definitely not tied to 1. My 12v is about 2Y old.
     
  2. AshokTexas

    AshokTexas Junior Member

    Joined:
    May 8, 2022
    36
    3
    0
    Location:
    Texas
    Vehicle:
    2008 Prius
    Model:
    III
    I was just researching on potential costs in case hv battery is bad and found that Toyota is no longer supplying, 2008 Prius battery G951047031; bad news as we have to rely on aftermarket reconditioned batteries. I am located in Tx and toyota parts center says product no longer available.
     
  3. AshokTexas

    AshokTexas Junior Member

    Joined:
    May 8, 2022
    36
    3
    0
    Location:
    Texas
    Vehicle:
    2008 Prius
    Model:
    III
    More info. Light flickered but still no codes read by dr. Prius. Battery temp recorded for all three above 120F but don’t know if it is normal or high. I am uploading some pics of tests I did. To me cells all look good with respect to each other, the delta is 0.16v across cells and internal resistance is even. Not knowing what nominal voltage is I suspect it is good.
     

    Attached Files:

  4. Tombukt2

    Tombukt2 Senior Member

    Joined:
    Nov 29, 2020
    2,811
    474
    0
    Location:
    Durham NC
    Vehicle:
    2009 Prius
    Model:
    Base
    Sounds like HV is not getting or taking charge inverter output or battery capacity issue my HV made 19 yrs and was dead at removal. Was gas engine only mid 30's for mpg during that issue.
     
  5. AshokTexas

    AshokTexas Junior Member

    Joined:
    May 8, 2022
    36
    3
    0
    Location:
    Texas
    Vehicle:
    2008 Prius
    Model:
    III
    . Before noticing of sluggishness I was getting about 44mpg and now it is to 37mpg.
     
  6. dolj

    dolj Senior Member

    Joined:
    May 14, 2012
    6,443
    3,358
    0
    Location:
    Wellington, New Zealand
    Vehicle:
    2007 Prius
    Model:
    N/A
    That is not true, they just might be out of stock. Contact Matt at Texas Hybrid Batteries. He can do a good price and supply a Toyota new unit for you.
     
    ColoradoCrow and jerrymildred like this.
  7. AshokTexas

    AshokTexas Junior Member

    Joined:
    May 8, 2022
    36
    3
    0
    Location:
    Texas
    Vehicle:
    2008 Prius
    Model:
    III
    Thank you, I will keep troubleshooting before I invest.
     
  8. AshokTexas

    AshokTexas Junior Member

    Joined:
    May 8, 2022
    36
    3
    0
    Location:
    Texas
    Vehicle:
    2008 Prius
    Model:
    III
    Okay, this correlation might not be at all true. I decided to check my engine oil level, and the level was right at the tip of my dipstick, way too low. I think engine is burning it as there not wet spots under the car. But ever since I filled the engine oil to proper level the HV battery is no longer dipping below 60% and the sluggish acceleration as also gone. The gas mileage is also inching up slowly as I do not reset it very often. Now it is been only three days of trouble free running.
     
    jerrymildred likes this.
  9. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    100,072
    45,360
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    could be. oil starvation = poor engine performance = more hybrid battery use?

    how many miles on her? they do become oil burners after awhile, especially if you let it slip below the low mark.
    cylinder wear just exacerbates the problem
     
  10. jerrymildred

    jerrymildred Senior Member

    Joined:
    Oct 28, 2016
    11,151
    13,618
    0
    Location:
    Tampa, FL
    Vehicle:
    2017 Prius
    Model:
    Two
    I was going to mention that the occasional red triangle usually indicates that the car is burning oil and the driver isn't keeping an eye on it. When the oil pressure drops, the light comes on and the engine rubs bare metal on bare metal which causes damage.

    But I don't see the connection between that and the hybrid battery behavior you're describing. That just sounds like a battery that's lost capacity. Unless ... maybe it was so bad that the engine was on the verge of seizing which would make the battery feed more power to the motors to compensate.
     
  11. AshokTexas

    AshokTexas Junior Member

    Joined:
    May 8, 2022
    36
    3
    0
    Location:
    Texas
    Vehicle:
    2008 Prius
    Model:
    III
    It got 149K miles. Okay after engine oil replenishment update, No more sluggish behavior, triangle light & mielage is up to 43-44mpg as before, but sudden drop of capacity from 6 to 8 bars to 2 bars happens, especially mornings. I drive probably .25miles and it drops to two bars and in another two miles or less (morning school drop commute with speeds of 30-35mph and one stop light) it comes back up to 6 bars. I cleaned the battery air circulating fan best I could with a toothbrush as well. Number 1 is now joined with squeaking sound, and squeaking happens even at stand still. Wonder if they sell a rebuild kit for the ABS actuator, cause to replace those things seems to be a very difficult as well as expensive, getting to the resistor seems even harder as u have to remove the dash.
     
  12. AshokTexas

    AshokTexas Junior Member

    Joined:
    May 8, 2022
    36
    3
    0
    Location:
    Texas
    Vehicle:
    2008 Prius
    Model:
    III
    Okay, no sluggish behavior after oil change. Drove close to 1000mi after oil replenishment. But I do think my abs brake actuator is going bad though. When I turn on the Prius I get this long beep with abs, vac lights lit up. The lights go away after few (4) seconds. I need to start shopping around for one on google. These things are expensive and I don’t mind getting a rebuild kit to rebuild them but I don’t see such kits out there. Any links for OEM parts with good prices is appreciated.
     
  13. edthefox5

    edthefox5 Senior Member

    Joined:
    Jul 25, 2007
    9,852
    4,633
    0
    Location:
    Clearwater, Florida
    Vehicle:
    2007 Prius
    Model:
    Two
    She’s going to be an oil eater now. I would check it every morning before starting the car see how bad it is.

    Keep it at the full line now always. It will help if you move to a 40 weight oil.
     
  14. AshokTexas

    AshokTexas Junior Member

    Joined:
    May 8, 2022
    36
    3
    0
    Location:
    Texas
    Vehicle:
    2008 Prius
    Model:
    III
    Well, today VSC, ABS, BRAKE all came on and stayed on. So time for new ABS actuator assembly. Been looking everywhere but the things are a bit expensive.

    Anybody suggest scan tool to read abs codes. My veepak & dr.prius app does not. it looks like not all abs code readers work across all vehicles.

    Thanks
    Ashok
     
    #14 AshokTexas, Jun 9, 2022
    Last edited: Jun 9, 2022
  15. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    100,072
    45,360
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    tech stream/mini vci is the prius gold standard. bit of a hassle to set up sometimes, from what i've read
     
  16. mr_guy_mann

    mr_guy_mann Senior Member

    Joined:
    Sep 3, 2020
    2,142
    845
    0
    Location:
    NJ-USA
    Vehicle:
    2006 Prius
    Model:
    Four
    At the top of the Gen2 Technical discussion forum, there is a sticky thread that reviews several apps. Short form, the Autel Maxi AP200 device and app has codes and data function for all ecu's on a Gen2(good tool for the price). The ThinkDiag device and app costs more but does more (is close to Techstream functionality) than the AP200.

    Posted via the PriusChat mobile app.
     
  17. AshokTexas

    AshokTexas Junior Member

    Joined:
    May 8, 2022
    36
    3
    0
    Location:
    Texas
    Vehicle:
    2008 Prius
    Model:
    III
    Well I went overboard and bought Techstream miniVCI, Autel MaxiAP200 & ThinkCar SR4 global scanner. I set up Techstream today and probably going to stick with it as it is designed for Toyota vehicles and return the others. Got 5 codes for ABS. C1241, C1242, C1256, C1300 & C1391. AC codes B1421, B1443. Now comes the research. I am hoping all the ABS codes are due to the leaky ABS actuator (but doubt it). No codes on HV battery side.

    The C1256 & C1391 is ABS pump leaking pressure. So new pump there. C1241 & C1242 are one it looks like I need electrical manual to diagnose further & C1300 is error with Skid Control Unit. If I replace Skid control unit ECU I have to do Zero point calibration. It might be easier to junk the darn car by the time I spend money fixing all these things. The ABS actuator & ECU both combined are minimum $2.2k for parts (new), before I get into C1241 & C1242. Don't know if should go used here! right now not an happy camper. If anyone can point me towards a 2008 repair & troubleshooting manual, mechanical & electrical for my prius would be great help.
     
    #17 AshokTexas, Jun 14, 2022
    Last edited: Jun 14, 2022
  18. AshokTexas

    AshokTexas Junior Member

    Joined:
    May 8, 2022
    36
    3
    0
    Location:
    Texas
    Vehicle:
    2008 Prius
    Model:
    III
    I read on this forum that you won't have regenerative braking when u have C1300 error. Which explains why Dr.Prius was not showing charge amps go up while braking after the ABS, VSC & Brake lights came on.
     
  19. dolj

    dolj Senior Member

    Joined:
    May 14, 2012
    6,443
    3,358
    0
    Location:
    Wellington, New Zealand
    Vehicle:
    2007 Prius
    Model:
    N/A
    Shop around for the actuator, Olathe Toyota has them discounted to $1135 regularly. I would not go new for the Skid Control ECU. They are pretty reliable and buying a used one should not be too expensive.
     
  20. AshokTexas

    AshokTexas Junior Member

    Joined:
    May 8, 2022
    36
    3
    0
    Location:
    Texas
    Vehicle:
    2008 Prius
    Model:
    III
    Anyone who can make more sense of this, but I pulled a detailed FFD data this morning. The only two available freeze frame data (FFD) I could pull out. Thinking of it not sure what will come out of it ;) but, my driver side head light flickers while driving and goes of eventually. But if I turn car off and turn it back on it will come back. So it could be that I have a wiring issue, and might be related to C1241 & C1242. Still looking for a EWD to diagnose these for 2008 prius.
     

    Attached Files:

Loading...