Pre-Collision and Cruise control are not working

Discussion in 'Gen 4 Prius Care, Maintenance and Troubleshooting' started by artie, Nov 12, 2020.

  1. artie

    artie Member

    Joined:
    Feb 5, 2004
    228
    59
    0
    Location:
    san diego
    Vehicle:
    2016 Prius
    Model:
    Three
    I have a 2016 gen 4 model 3 and while driving this afternoon in San Diego, clear skies, cruise was on, all of a sudden cruise cuts out and up pops notice: pre-collision system not working and cruise control not working. (It didn't say "not working", but it was something that meant just that, I forget the verbiage).
    85,000 trouble-free miles, anyone have any knowledge of these issues?
     
  2. hill

    hill High Fiber Member

    Joined:
    Jun 23, 2005
    17,088
    6,514
    54
    Location:
    South OC So Cal & Nashville, TN
    Vehicle:
    2004 Prius
    Model:
    IV
    just posted in another thread on codes, & code reading tools. Our readout (intermittent, so the dealer couldn't find it) on our scanner detected it, as well as what the apparent cause was ... a speed sensor. After they replaced it (under warranty) no more intermittent failures.
    even so ... it could be any number of other causes.
    .
     
  3. alanclarkeau

    alanclarkeau Senior Member

    Joined:
    Feb 24, 2016
    6,501
    7,087
    0
    Location:
    near Brisbane, Australia
    Vehicle:
    2016 Prius
    Model:
    N/A
    Check the sensors are clean (windscreen and LOGO in the grille).
     
  4. The Professor

    The Professor Senior Member

    Joined:
    Apr 5, 2018
    509
    701
    0
    Location:
    UK
    Vehicle:
    2017 Prius
    Model:
    Excel
    Yeah I had the same issue just the other day. The glass in front of the camera had misted up in the cold weather. Fixed itself the glass when it was clear again. So stuff obscuring the camera can definitely cause this.

    SM-T813 ?
     
    Harters and alanclarkeau like this.
  5. Harters

    Harters Active Member

    Joined:
    Dec 28, 2016
    251
    368
    0
    Location:
    UK
    Vehicle:
    2017 Prius
    Model:
    Excel
    Yes, I think I saw that mentioned in the manual somewhere.

    I had my first occurrence of rain interfering with the CC the other day when I was driving in really hard rain. I have seen it mentioned in the handbook, but it was the first time in over 3 years actually experiencing it. It felt very odd when the car suddenly started speeding up, so I decided to turn it off until the heavy rain had passed (y)
     
    alanclarkeau likes this.
  6. alanclarkeau

    alanclarkeau Senior Member

    Joined:
    Feb 24, 2016
    6,501
    7,087
    0
    Location:
    near Brisbane, Australia
    Vehicle:
    2016 Prius
    Model:
    N/A
    Yep - in cyclonic rain - or severe storms, it's not reliable. Only had it ½ doz times in 4½ years though. Also immediately afterwards when there is a lot of spray on a fast busy wet motorway - spooks the DRCC.
     
    Harters likes this.
Loading...