Prius 2007 Navigation Issue

Discussion in 'Gen 2 Prius Audio and Electronics' started by ImranKhan, Feb 6, 2021.

  1. ImranKhan

    ImranKhan New Member

    Joined:
    Feb 6, 2021
    1
    0
    0
    Location:
    Lahore Pakistan
    Vehicle:
    2007 Prius
    Model:
    II
    I have prius 2007
    There is a navigation issue that the MFD not supporting while pressing the navigation button and an error message appears that the navigation computer is not installed.
    there is a navigation computer under passenger seat pics. attached.
    it has no DVD room.
    is there anyone who help me regarding this issue?
     

    Attached Files:

  2. TMR-JWAP

    TMR-JWAP Senior Member

    Joined:
    Aug 12, 2016
    3,947
    4,397
    0
    Location:
    Columbia, SC
    Vehicle:
    2007 Prius
    Model:
    Touring
    In the first photo, the large white plug isn't inserted. It's hanging down and a bit hard to see. I'd start with plugging that in to see if the unit starts working.
     
  3. dolj

    dolj Senior Member

    Joined:
    May 14, 2012
    5,319
    2,864
    0
    Location:
    Wellington, New Zealand
    Vehicle:
    2007 Prius
    Model:
    N/A
    I think that is the seat occupancy sensor plug. If you look carefully you can see it is plugged in to a socket under the seat.
     
  4. TMR-JWAP

    TMR-JWAP Senior Member

    Joined:
    Aug 12, 2016
    3,947
    4,397
    0
    Location:
    Columbia, SC
    Vehicle:
    2007 Prius
    Model:
    Touring
    This is the nav computer I removed from my 2007 Canadian parts car and sold on ebay a few months ago. His plugs and sockets do look a bit different, looks like I have an older version, or he has a later year version installed that isn't compatible, or maybe his model is for his area. The arrow shows the one I was thinking may not be plugged in..

    Nav Comp with arrow.jpg
     
    #4 TMR-JWAP, Feb 6, 2021
    Last edited: Feb 6, 2021
  5. dolj

    dolj Senior Member

    Joined:
    May 14, 2012
    5,319
    2,864
    0
    Location:
    Wellington, New Zealand
    Vehicle:
    2007 Prius
    Model:
    N/A
    Oh yeah, true. I was focusing on the one on the left.

    I'm thinking maybe that has been deliberately unplugged due to there being no DVD in the drive.
     
Loading...