Prius ac starts cooling at 30km

Discussion in 'Gen 2 Prius Technical Discussion' started by Alexano, Aug 11, 2019.

  1. Alexano

    Alexano New Member

    Joined:
    Mar 12, 2019
    18
    0
    0
    Location:
    Mars
    Vehicle:
    2007 Prius
    Model:
    N/A


    I am facing strange problem with my Prius 2007 model. Ac starts cooling when i reach speed of 30km / hour. It just thowes normal air bellow 30km. (Even at 29/km).

    It seems something is programmed to 30km exactly. I checked its fuse and relays and fans but all things are working fine. My local technician recommend me to change compressor. I replaced compressor and condenser but problem is still there. It works perfect whenever it reaches at speed of 30km.

    Both fans are working fine (in low and high speed also). Theres no code when i check it with Techstream.

    I am completely stuck with that problem. Can anybody guide me whats going on with my Prius?
     
  2. edthefox5

    edthefox5 Senior Member

    Joined:
    Jul 25, 2007
    7,369
    3,118
    0
    Location:
    Clearwater, Florida
    Vehicle:
    2007 Prius
    Model:
    Two
    Ac that only works at speed is fan issue. Either the fan is dead or it’s a salvage car and had front end damage
    And the fan was replaced but put on backwards. So it’s pushing instead of pulling. Sometimes the fan power connector gets burned up,

    Put the car in ready put the ac on max cool open the hood and both fans should be on at max speed pulling air from the front. You should feel strong sir if you put your hand on the fans.

    Or the front condenser is extremely dirt clogged or damaged. If you loose the Bottom protective plastic cover it opens up the condenser to possible road fod.

    Or the hybrid battery is on its last legs. First thing that fails with a very bad hybrid battery is the electrically powered compressor.
     
    SFO likes this.
  3. Alexano

    Alexano New Member

    Joined:
    Mar 12, 2019
    18
    0
    0
    Location:
    Mars
    Vehicle:
    2007 Prius
    Model:
    N/A
    Both fans are throwing fast air when AC turns on. I tried by removing front bumper to check if it is stopping air, but it also didn't worked.

    I am still not able to get connection of AC with 30km speed. Why it is not working at 29km but works fine at 30km?
     
  4. edthefox5

    edthefox5 Senior Member

    Joined:
    Jul 25, 2007
    7,369
    3,118
    0
    Location:
    Clearwater, Florida
    Vehicle:
    2007 Prius
    Model:
    Two
    Whats the hybrid battery look like on the mfd when that happens?
     
  5. Alexano

    Alexano New Member

    Joined:
    Mar 12, 2019
    18
    0
    0
    Location:
    Mars
    Vehicle:
    2007 Prius
    Model:
    N/A
    It happens all the time until my car speed touchs 30km/h. Hybrid battery is in good condition when we check it with techstream. Also it is holding good power and charging smoothly.
     
  6. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    82,205
    35,691
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    does it make any difference if the engine is on or off?
     
  7. Alexano

    Alexano New Member

    Joined:
    Mar 12, 2019
    18
    0
    0
    Location:
    Mars
    Vehicle:
    2007 Prius
    Model:
    N/A
    No, same behaviour.
     
  8. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    82,205
    35,691
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    are the fans spinning in the correct direction?
     
  9. Alexano

    Alexano New Member

    Joined:
    Mar 12, 2019
    18
    0
    0
    Location:
    Mars
    Vehicle:
    2007 Prius
    Model:
    N/A
    Yes they are spinning in right direction.
     
Loading...