Prius Bluetooth won't forget old phone

Discussion in 'Prius v Technical Discussion' started by katia0415, Jul 24, 2019.

  1. katia0415

    katia0415 New Member

    Joined:
    Jul 24, 2019
    1
    0
    0
    Location:
    Colorado
    Vehicle:
    2010 Prius
    Model:
    V


    I have a 2010 Prius V and I've had a really hard time getting the Bluetooth to connect to my new iPhone. No matter what, when I try to play media, the system will only try to connect to my old Samsung Galaxy S7.

    I have deleted all phones from the system, then I added my iPhone as the only phone in the car's menu. It connects to the Bluetooth. Then, when I try to play media on it (by going to the Audio option and clicking Bluetooth), it says my BT is disconnected and tries to connect to the Galaxy S7, despite the fact that I deleted the phone from the system. Then my iPhone disconnects from the Bluetooth.

    It is baffling, but for some reason my Prius has not forgotten the Galaxy S7 (despite my having deleted all phones from the system) and ONLY wants to connect to that when it plays media over Bluetooth. Is there any way to completely reset the media system in the Prius?
     
  2. RickNinePlus

    RickNinePlus New Member

    Joined:
    Jul 26, 2019
    2
    0
    0
    Location:
    Oregon
    Vehicle:
    2010 Prius
    Model:
    Four
    Having the same problem with my 2010 Prius! Deleted all old phones but still wants to connect to them when I try to play audio from my iPhone 8. Hope we can find some answers soon.
     
  3. Offline

    Offline Active Member

    Joined:
    Sep 3, 2012
    625
    217
    0
    Location:
    Lenexa, Kansas
    Vehicle:
    2012 Prius v wagon
    Model:
    Five
  4. RickNinePlus

    RickNinePlus New Member

    Joined:
    Jul 26, 2019
    2
    0
    0
    Location:
    Oregon
    Vehicle:
    2010 Prius
    Model:
    Four
    I found a solution on an Apple forum and it worked for me! Finally got audio in my Prius. But PriusChat won't let me post a link so look up "Prius Bluetooth audio won't forget old phone" on Google and it's like the third hit in Apple's discussion forum. Hope it helps!
     
  5. JonIowa

    JonIowa New Member

    Joined:
    Jan 18, 2020
    2
    1
    0
    Location:
    Modesto, CA 95355
    Vehicle:
    2011 Prius
    Model:
    V
    My wife's 2011 Prius had the problem where the phone calls would go through her new phone, but the BT Audio was still trying to connect to her old phone. The trick was to delete the old portable players in the Setup/Audio menu and then it is not very clear. It looks like you are deleting the car itself, but it will show you the old portable player(s) then you can delete them. Very convoluted. When it works it is good, but configuring it, can be a hassle. I try to remember this was implemented/built in 2010 so that is a long time ago ;)

    Hope that helps. Not really a phone problem.
     
  6. icyrius

    icyrius Member

    Joined:
    Apr 10, 2016
    164
    76
    7
    Location:
    Florida, USA
    Vehicle:
    2014 Prius v wagon
    Model:
    Three
    There is no work around this. I have been trying to fix this for years.
     
  7. Offline

    Offline Active Member

    Joined:
    Sep 3, 2012
    625
    217
    0
    Location:
    Lenexa, Kansas
    Vehicle:
    2012 Prius v wagon
    Model:
    Five
    Maybe the previous post - post #5 - will help you. Toyota head units don't all work the same when it comes to phones used as portable players. In some like my wife's 2012 Prius v Five with the JBL head unit, deleting a phone for calls also deletes it from the portable player list.

    Our 2014 Sienna JBL with nav works like joniowa described for his wife's 2010 Prius. Deleting a phone used for phone calls does not deleted it from the portable player list. One has to find the additional set up screen in the in-dash unit that is only for portable players and delete the phone from there too
     
Loading...