Prius C need help

Discussion in 'Prius c Care, Maintenance and Troubleshooting' started by Javierz0509, Dec 7, 2017.

  1. Javierz0509

    Javierz0509 Junior Member

    Joined:
    Jun 16, 2017
    55
    13
    0
    Location:
    Miami
    Vehicle:
    2013 Prius c
    Model:
    One
    my prius c is a 2013, today as i was going to the store my check hybrid system light came on, i suspect is my 12v battery because the car been good so far, now if its the battery how can i reset the error once i install a new 12v battery????

    is there anything else to check?
     
  2. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    61,191
    21,464
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    you need to read the codes, test the hybrid battery, and clean the hybrid battery intake grille and fan.

    how many miles on her?
     
  3. Javierz0509

    Javierz0509 Junior Member

    Joined:
    Jun 16, 2017
    55
    13
    0
    Location:
    Miami
    Vehicle:
    2013 Prius c
    Model:
    One

    I am now worry, took the 12v battery to get check it was reading 13.0v 100%, I'm going to put it back is there a way to reset the hybrid system?
     
  4. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    61,191
    21,464
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    disconnect the 12v for a few minutes. if that doesn't work, you need a code reader to reset it. ask the people who tested the 12v.
     
  5. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    61,191
    21,464
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    13v is very high for a 4-5 year old battery, how was it tested?
     
  6. Javierz0509

    Javierz0509 Junior Member

    Joined:
    Jun 16, 2017
    55
    13
    0
    Location:
    Miami
    Vehicle:
    2013 Prius c
    Model:
    One
    Update, so my wife was on her way home and i decided to take the battery off while i waited for her, the battery stood there alone for 1 hr, my wife comes in and takes me to autozone and the guy tested the battery and gave us 13.0v 100% good. So i came back home and before connecting the 12v bat i notice the hybrid battery connector and unplug it and plug it back in, then i connected the 12v battery and the car ran OK with no issue i even took it around the block it went into EV and all....WTFFF

    could it be that since i left the 12v battery alone for 1 hour and took it to autozone to test it gain charge and gave us 13.0 volt. ? need more ideas.
    btw the car has been running good 50 to 60mpg.
     
  7. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    61,191
    21,464
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    hopefully, someone else will chime in, i'm fresh out of ideas. please let us know if the warning comes back.
     
  8. Javierz0509

    Javierz0509 Junior Member

    Joined:
    Jun 16, 2017
    55
    13
    0
    Location:
    Miami
    Vehicle:
    2013 Prius c
    Model:
    One
    update from this morning, i turn on the car and i have one of those volt meters that plugs into the 12v connector and i notice that the engine was on and giving me 14.2 then when the engine turns off and ev kicks in the meter say 13.7 it was not like that before it would always say 14.0 or 14.2
     
  9. Javierz0509

    Javierz0509 Junior Member

    Joined:
    Jun 16, 2017
    55
    13
    0
    Location:
    Miami
    Vehicle:
    2013 Prius c
    Model:
    One
    update: my ac fan blower motor started smelling a bit funny like its going to burn out, last week started acting up, i still dont have no hybrid error but i notice the ac fan blower stop all of the sudden i tried to turn it back on and it started smelling, i think this is what cause my first hybrid system error.
     
Loading...