Prius ERROR code POA90

Discussion in 'Gen 3 Prius Main Forum' started by nasrah, Sep 26, 2011.

  1. nasrah

    nasrah New Member

    Joined:
    Sep 26, 2011
    1
    0
    0
    Location:
    CANADA
    Vehicle:
    2008 Prius
    Model:
    Three
    I have a trouble with my 2008 prius; red triangle engine light is coming and when i try to push the gas pedal it feels like it's freeze, the car do not accelerate so i have to stop. After i turn it off and start again it drives ok, but triangle is still there and there is error code POA90 ( two different scanners shows same code with two descriptions; the forst is "MOTOR PERFORMANCE"; the second describe it as "14 volt power module system voltage high"). Speccialy it happens when i drive up the hill and push the gas pedal harder. Does anyone know what it can be? I took the car to the Toyota dealer; they looked for 8 hours and find nothing :confused:; i can't do it again as the car do not have a warranty and the dealer charge by hours! Please help if anyone have any clue, thank you
     
  2. seilerts

    seilerts Battery Curmudgeon

    Joined:
    Mar 7, 2010
    3,326
    1,506
    38
    Location:
    Santa Fe, NM
    Vehicle:
    2005 Prius
    P0a90 is most likely a transaxle problem. But there is a 3 digit code information code that is crucial to a complete diagnosis. Please ask your dealer for that 3 digit code associated with the p0a90 and post it here. But it is usually the transaxle.
     
    1 person likes this.
  3. telmo744

    telmo744 HSD fanatic

    Joined:
    Apr 8, 2010
    2,142
    751
    0
    Location:
    Portugal
    Vehicle:
    2010 Prius
    Model:
    N/A
    If 14Volt system voltage is high, maybe the auxiliary battery is shot?
     
  4. Teakwood

    Teakwood Member

    Joined:
    Jun 23, 2010
    491
    73
    0
    Location:
    New Mexico
    Vehicle:
    2010 Prius
    Model:
    II
    Je crois que une visite au département de service serait appropriée, si vous voulez.
     
Loading...