Prius v maintenance required light won’t reset

Discussion in 'Prius v Care, Maintenance and Troubleshooting' started by Dezhan, Oct 4, 2018.

  1. Dezhan

    Dezhan Junior Member

    Joined:
    Oct 4, 2018
    6
    2
    0
    Location:
    San Diego
    Vehicle:
    2014 Prius v wagon
    Model:
    V
    New. Hello everyone.
    My 2014 Prius v maintenance required light won’t reset. So far i have followed the instructions on the owner’s manual but was unsuccessful. And took to local Toyota dealership for an oil change and they were unable to reset the maintenance required light. They could not explain why it won’t reset or shut off. Help please
    Thank you
     
  2. rjparker

    rjparker Senior Member

    Joined:
    Jun 6, 2008
    3,042
    1,436
    2
    Location:
    Texas Hill Country
    Vehicle:
    2012 Prius v wagon
    Model:
    Three
    I might check the km/h-mph button for operation since its part of the maintenance reset procedure

    prius v reset maintenance.jpg
     
  3. Dezhan

    Dezhan Junior Member

    Joined:
    Oct 4, 2018
    6
    2
    0
    Location:
    San Diego
    Vehicle:
    2014 Prius v wagon
    Model:
    V
    Thank you. km/h-mpg button is functional. It switches back and forth from km/h-mpg.
     
  4. rjparker

    rjparker Senior Member

    Joined:
    Jun 6, 2008
    3,042
    1,436
    2
    Location:
    Texas Hill Country
    Vehicle:
    2012 Prius v wagon
    Model:
    Three
    Then I might disconnect the 12vdc power for 5 minutes and start fresh. It will reset the trip a & b meters to zero along with the clock and a few other things.
     
  5. Dezhan

    Dezhan Junior Member

    Joined:
    Oct 4, 2018
    6
    2
    0
    Location:
    San Diego
    Vehicle:
    2014 Prius v wagon
    Model:
    V
    No luck. I disconnected the 12v battery for five+ minuets and it still stayed on. I then followed the owners manual instructions to reset it. Unfortunately, didn’t work. Might be irrelevant questions regarding maintenance light. Do you think getting an alignment may help? Steering wheel is very slightly to the right.
     
  6. Hosinhala

    Hosinhala New Member

    Joined:
    Sep 12, 2019
    1
    0
    0
    Location:
    San Jose ca
    Vehicle:
    2013 Prius v wagon
    Model:
    ----USA----
    Did you ever find a solution!
     
  7. Dezhan

    Dezhan Junior Member

    Joined:
    Oct 4, 2018
    6
    2
    0
    Location:
    San Diego
    Vehicle:
    2014 Prius v wagon
    Model:
    V
    Sorry for the late response. I haven't found any solution yet. I went to Toyota dealership few times again and hoping someone might have an answer to the problem. However, they can't tell why it won't reset.
     
  8. eagle eye

    eagle eye Junior Member

    Joined:
    Nov 3, 2016
    10
    3
    0
    Location:
    texas
    Vehicle:
    2015 Prius v wagon
    Model:
    Three
    This works with my 2015 v3:

    Using the control with the four arrows on the right side of the steering wheel, open the display on the dash.
    Press the left arrow, scroll from the letter i in the square to the settings (gear) icon. Press the button in the center of the arrows to go to settings. Scroll to Maintenance System and select with the center button. There you can initialize the system to reset the maintenance alert.
     
  9. Dezhan

    Dezhan Junior Member

    Joined:
    Oct 4, 2018
    6
    2
    0
    Location:
    San Diego
    Vehicle:
    2014 Prius v wagon
    Model:
    V
    I don't see any option with for arrows. This what I see on my 2014 Prius V steering wheel. Radio control on the left side and climate control on the right side of the the steering wheel.
     
    iLikeTurtles likes this.
  10. iLikeTurtles

    iLikeTurtles Junior Member

    Joined:
    Jul 2, 2018
    11
    3
    0
    Location:
    Portland, OR
    Vehicle:
    2014 Prius v wagon
    Model:
    Three
    I have the same problem as you with my light not resetting. 2014 V trim 3
     
  11. Dukeswalker

    Dukeswalker New Member

    Joined:
    Jan 7, 2020
    1
    0
    0
    Location:
    Arizona
    Vehicle:
    2015 Prius v wagon
    Model:
    Three
    I found this on another post and it worked!! Yay!!
    1. Turn the car on.
    2. In the heads-up display on the top of the dash, use the navigation pad on the steering wheel to navigate (left or right) to the gear icon, which is "Settings". Hit the center button to select.
    3. Navigate down to the "Maintenance System" menu item. Hit the center button to select.
    4. At the "Do you want to initialize?" prompt, select "Yes". Hit the center button
     
  12. Dezhan

    Dezhan Junior Member

    Joined:
    Oct 4, 2018
    6
    2
    0
    Location:
    San Diego
    Vehicle:
    2014 Prius v wagon
    Model:
    V
    Yesterday when I started the Prius the maintenance light was off. After two years driving with the light on and trying all the suggestions it didn't work and suddenly off. I have no explanation to why it would not reset and why it is off now.
     
    bisco likes this.
  13. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    91,804
    41,416
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    have you ever used msdos?
     
  14. Algernon

    Algernon New Member

    Joined:
    Mar 13, 2021
    1
    0
    0
    Location:
    Conway
    Vehicle:
    2012 Prius
    Model:
    ----USA----
    I kept failing to reset mine on my 2012 Prius, then tried having it in k/hr mode first, holding the mi/hr/k/hr button in, pushing the power button while still holding the per-hour button in, then pushing Power twice, continuing to hold the per-hour button as the loading bar indicated resetting the "Maintenance Required".

    The whole time, I had my foot on the brake if i remember correctly.
     
  15. Eli McA

    Eli McA New Member

    Joined:
    Mar 19, 2021
    2
    0
    0
    Location:
    CA
    Vehicle:
    2013 Prius v wagon
    Model:
    V
    I’m curious to know if it is still out because it seems like you got lucky and the bulb just went out. I have the same issue with my 2013 Prius C. First had my oil change guy try and fail, then I tried a million things myself, and then took it to the dealership who couldn’t figure it out either. Let me know if it’s off when you get a minute.

    Does anybody have a schematic of the circuit that connects to this light?
     
Loading...