Problems charging when driving

Discussion in 'Gen 2 Prius Care, Maintenance and Troubleshooting' started by blankity, Oct 11, 2021.

  1. blankity

    blankity Junior Member

    Joined:
    Jul 4, 2017
    7
    0
    0
    Location:
    Panama City, Florida
    Vehicle:
    2008 Prius
    Model:
    N/A
    I seem to be having some regeneration problems. My Prius doesn't seem to want to charge the HV battery when I'm driving/braking. Eventually, when it reaches 1 bar I begin to lose acceleration before it throws P3190 and I lose Ready mode. It does charge perfectly fine when in P however. An interesting note, when I attempt to manually charge the HV battery when it is low (two bars), it acts sporadic and doesn't charge the battery before eventually throwing P3190 again (also P0A0F as well upon restarting the car). After clearing the codes and letting the car self charge the battery to about 45%, I can then manually charge the battery by putting it in D and pressing both the brake and gas pedals. It doesn't seem to have any problems charging the battery when said battery already has a good chunk of charge to it. However, the car still doesn't seem to want to charge it while driving. The only code I saw of note is C1245 in techstream. But I kinda figured that was a given if it's not charging when driving.


    Now for some side information:

    I had the HV completely replaced in Nov 2018 from Green Bean Battery. I don't think it's the battery though, since Dr. Prius shows it to be fine.

    Few months ago, the brake control power supply assembly had a voltage leak at the connector. It threw C1245 and blew my ABS-2 fuse. I replaced it with one from a 2007 Prius. The model number, after the prefix, was lower than mine but I figured they were close enough. I also had to cut two wires and replace the connector itself where it had corroded. Car seemed to run fine after this so I assume the problem was fixed.

    I recently took it to a mechanic to have the exhaust flange and bolts replaced as they were making a loud rattling noise and leaking. Now there's a hissing noise coming from the exhaust manifold but I'm not entirely sure and will be taking it back to the mechanic to have it looked at. Possibly was already leaking and just couldn't hear it over the loud rattle.

    And just yesterday, I fixed a grounding problem that was causing my backup camera to come on when the turn signal was on and also causing the turn signal to blink rapidly. This was actually a new problem that occurred after getting the car back from the mechanic. Not even sure how the connector snapped since the mechanic shouldn't have been anywhere near it but it did and I fixed it.

    Out of curiosity this morning, I checked the oil levels and it was about and inch and a half above the 2nd dot. I haven't had to put much oil in it in awhile since replacing the spark plugs earlier this year so I'm not sure where the extra oil came from. But I can't imagine that would be the source of my problems.


    Only other codes I have are P1116 and P1121 and a rogue P0420 that never wants to go away no matter what I do. The only thing that bothers me here is that the car was running fine (fine in the sense that I could get from point A to B with no issues) before taking it to the mechanic. The rattle was annoying as hell sure and leaking exhaust is bad but I was still able to make it to work. My only theory is that maybe when they were messing with that pipe that it dislodged the manifold more, or exasperated the problem more and now my ICE is choking? Either way I wil get it looked at Tuesday and if that is what's causing the hissing noise then have it replaced too.
     
  2. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    94,734
    42,960
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    what does the 3190 indicate?
     
  3. PriusCamper

    PriusCamper Senior Member

    Joined:
    Mar 3, 2012
    6,362
    2,673
    0
    Location:
    Pacific Northwest, USA
    Vehicle:
    2007 Prius
    Model:
    Two
    You have to put on your googley eyes and see what it says:

    Screenshot from 2021-10-11 10-49-37.png
     
  4. SFO

    SFO Senior Member

    Joined:
    Feb 7, 2017
    4,226
    3,881
    0
    Location:
    Northern California
    Vehicle:
    2007 Prius
    Model:
    N/A
    How many miles are on the vehicle currently?
    Do you already have, or need the workups for the mentioned OBD2 codes (DTCs)?
    What have you already tried in relation to the above DTC P0420?
     
  5. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    94,734
    42,960
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    LOL, i think the o/p could do that without our help :cool:
     
  6. ChapmanF

    ChapmanF Senior Member

    Joined:
    Mar 30, 2008
    14,644
    10,282
    0
    Location:
    Indiana, USA
    Vehicle:
    2010 Prius
    Model:
    IV
    If the question is "what does it indicate?", you look in the repair manual, and find out it indicates the engine was producing less than 20% of its target torque, at a time when it was not being started, RPM was above a minimum, and communication with the HV ECU was normal.

    If the question is "what do 500 random BSers on the internet think it means?", you use the googley eyes and get the answer to that.

    Both methods answer their respective questions.
     
Loading...