1. Attachments are working again! Check out this thread for more details and to report any other bugs.

Problems with Dynamic Radar Cruise Control?

Discussion in 'Gen 4 Prius Care, Maintenance and Troubleshooting' started by Hydrocket, Feb 18, 2021.

  1. Harters

    Harters Active Member

    Joined:
    Dec 28, 2016
    335
    423
    0
    Location:
    UK
    Vehicle:
    2017 Prius
    Model:
    Excel
    Have you checked there is not fogging on the inside of the windscreen that goes over the sensor? I have heard of that causing an issue with the ACC and is mentioned in the manual somewhere.
     
  2. Doug McC

    Doug McC Active Member

    Joined:
    Feb 15, 2022
    947
    347
    0
    Location:
    Midwest
    Vehicle:
    2022 Prius
    Model:
    XLE
    It does for the wipers (5 degrees Fahrenheit), but for the DCC it just says extreme cold temperatures (for the hybrid system itself it says -22 degrees Fahrenheit).
     
  3. Hydrocket

    Hydrocket Member

    Joined:
    Oct 4, 2020
    77
    39
    0
    Location:
    CA
    Vehicle:
    2017 Prius Prime
    Model:
    Technology
    It's much less cold today..and the problem persists. It's like a switch is turned on preventing DRCC from working (like in our LS when in Snow Mode).

    You turn it on...and no faults (Radar Ready). But as soon as you set the speed (and you can feel the DRCC start to work for a split second) it errors out.

    Very perplexing
     
  4. Hydrocket

    Hydrocket Member

    Joined:
    Oct 4, 2020
    77
    39
    0
    Location:
    CA
    Vehicle:
    2017 Prius Prime
    Model:
    Technology
    Still no joy here.
     
  5. AzWxGuy

    AzWxGuy Weather Guy

    Joined:
    May 22, 2011
    965
    489
    0
    Location:
    Tucson, AZ
    Vehicle:
    2021 Prius
    Model:
    Limited
    Might have to spring for a dealer service call.
     
  6. Nate_F

    Nate_F Junior Member

    Joined:
    Dec 30, 2016
    25
    7
    0
    Location:
    Idaho
    Vehicle:
    2017 Prius Prime
    Model:
    Prime Premium
    Been having the same problem as the original poster for a few weeks now with no 'clean sensor message' ever appearing.

    I was driving at 70mph on a straightaway with no one in front of me with DRCC engaged. Cruise turned off without warning or any obvious change in terrain, speed or weather. I stopped quickly thereafter and cleaned off a bit of ice snow from the front badge which accumulated either the day before or maybe 30 minutes prior (weather was clear and road was dry when cruise stopped working). DRCC still failed to engage. I stopped about 10 miles later and noticed condensation inside the camera cavity so I cleaned that up but made no difference. It hasn't worked once since. Just like the OP, it engages for a split second where I can feel the car lurch forward a bit and then disengages. I didn't realize until today that DRCC can be disabled by holding the cruise on/off button, and 'normal cruise' still works.
     
  7. Doug McC

    Doug McC Active Member

    Joined:
    Feb 15, 2022
    947
    347
    0
    Location:
    Midwest
    Vehicle:
    2022 Prius
    Model:
    XLE
    It is interesting that both cars are 2017 Primes. I would take it to the dealer because my bet would be something went wrong in the electronics, especially since regular Cruise Control works.
     
  8. Doug McC

    Doug McC Active Member

    Joined:
    Feb 15, 2022
    947
    347
    0
    Location:
    Midwest
    Vehicle:
    2022 Prius
    Model:
    XLE
    Did by any chance either one of you disconnect the 12 volt battery shortly before the problem started? This is just a SWAG, but I wonder if it could be one of those things that needs a reset if 12 volt power is lost.
     
  9. Nate_F

    Nate_F Junior Member

    Joined:
    Dec 30, 2016
    25
    7
    0
    Location:
    Idaho
    Vehicle:
    2017 Prius Prime
    Model:
    Prime Premium
    Negative. I was driving and using drcc for about an hour when it mysteriously cancelled cruise and never worked again.
     
  10. jerrymildred

    jerrymildred Senior Member

    Joined:
    Oct 28, 2016
    11,491
    14,097
    0
    Location:
    Tampa, FL
    Vehicle:
    2017 Prius
    Model:
    Two
    I've disconnected my 12V lots of times and had no issues with DRCC. If it's not crud blocking the radar or the camera, then I'd say you should have a dealer check it.
     
  11. Doug McC

    Doug McC Active Member

    Joined:
    Feb 15, 2022
    947
    347
    0
    Location:
    Midwest
    Vehicle:
    2022 Prius
    Model:
    XLE
    True, but some weird things have happened when the battery has been disconnected and if BOTH had just done that…. Well it doesn’t matter anyway since that isn’t a commonality.
     
    jerrymildred likes this.
  12. Hydrocket

    Hydrocket Member

    Joined:
    Oct 4, 2020
    77
    39
    0
    Location:
    CA
    Vehicle:
    2017 Prius Prime
    Model:
    Technology
    Negative.


    Mine is working again.

    Seems related to (but I'm not sure) is excess humidity. The Pre heating steams the windows and it's stopped working. Then 2 weeks later, it works again. I then took a long road trip, had some snow on floor mats and noticed humidity on windows. Next day, no cruise.

    So I think but not sure...camera might be getting steamed? Maybe inside or on the reader lense?

    Ordered a used camera unit to pop in next time it misbehaves.

    But I'm still not sure exactly what causes it
     
    #32 Hydrocket, Feb 20, 2023
    Last edited: Feb 20, 2023
  13. AzWxGuy

    AzWxGuy Weather Guy

    Joined:
    May 22, 2011
    965
    489
    0
    Location:
    Tucson, AZ
    Vehicle:
    2021 Prius
    Model:
    Limited
    I had this same sequence of events happen to me yesterday on the way back home from work. When I started out, it was just rain. Then rain changed to rain and snow mix, outside air temp 37 F. Then at a temperature of 34 F it was mostly snow and sticking on the windshield and rearview mirrors. Then I got the error message and the car dropped out of cruise. I suspect but didn't confirm that snow and slush had built up on the front Toyota badge, behind which is the DRCC unit. Just outside of town, at a lower elevation and temp of 40 F, I was able to enable it again. And today it worked perfectly.
     
    jerrymildred likes this.
  14. Nate_F

    Nate_F Junior Member

    Joined:
    Dec 30, 2016
    25
    7
    0
    Location:
    Idaho
    Vehicle:
    2017 Prius Prime
    Model:
    Prime Premium
    That's the normal sequence for sticky snow. Our symptoms are different where cleaning the sensor has no effect.
     
  15. Nate_F

    Nate_F Junior Member

    Joined:
    Dec 30, 2016
    25
    7
    0
    Location:
    Idaho
    Vehicle:
    2017 Prius Prime
    Model:
    Prime Premium
    Took it to my dealer today and they weren't able to figure it out. They are going to have me make another appointment after they consult with Toyota.
     
  16. Hydrocket

    Hydrocket Member

    Joined:
    Oct 4, 2020
    77
    39
    0
    Location:
    CA
    Vehicle:
    2017 Prius Prime
    Model:
    Technology
    Please keep us posted.

    Very curious on the outcome
     
  17. Nate_F

    Nate_F Junior Member

    Joined:
    Dec 30, 2016
    25
    7
    0
    Location:
    Idaho
    Vehicle:
    2017 Prius Prime
    Model:
    Prime Premium
    Fixed. The dealer tech said he performed a radar sensor calibration and it worked after that. He said it was a normally a ~$300 procedure, but the dealer only charged me the diagnosis fee ($140).

    Here's a video I just found for the procedure on a 2019 -
     
    jerrymildred likes this.