Radio/ CD stopped working

Discussion in 'Gen 2 Prius Audio and Electronics' started by aanimate, Dec 12, 2010.

  1. aanimate

    aanimate New Member

    Joined:
    Mar 31, 2005
    25
    0
    0
    My radio and cd suddenly stopped working.
    Drove in the evening everything was fine, turned on the car in the morning and power button doesn't turn on radio; voice, mode, volume, handsfree buttons, don't work.
    My navigation works fine with voice. I can still call but have to dial through my cell phone.
    None of the light on radio/cd work.
    I checked fuses and they are all good.
    Anybody have any suggestions ideas?
    thank you.:confused:
     
  2. Boo

    Boo Boola Boola Member

    Joined:
    Feb 13, 2007
    5,051
    471
    97
    Location:
    Flushing, NY
    Vehicle:
    2007 Prius
    Model:
    N/A
  3. aanimate

    aanimate New Member

    Joined:
    Mar 31, 2005
    25
    0
    0
  4. Hal W

    Hal W New Member

    Joined:
    Sep 26, 2010
    872
    53
    0
    Location:
    Grand Forks,B.C. Canada
    Vehicle:
    2006 Prius
    Model:
    II
    Did you check the fuse/ H
     
  5. aanimate

    aanimate New Member

    Joined:
    Mar 31, 2005
    25
    0
    0
    I looked at the manual and check all the fuses related to "audio system"
    Even replaced the main "audio system" fuse, I think number 45 or 46, with a new one, but no go. Unless there is a possibility that other fuses not marked with "audio system" in their description can cause radio not to work.
    I wonder if it's possible that cables in the back of the radio come undone?
    But the way they fit it is probably very low possibility.
     
  6. aanimate

    aanimate New Member

    Joined:
    Mar 31, 2005
    25
    0
    0
    Today, after work, got into my car and radio is working!
    One thing I didn't mention is that I went to Tahoe over the weekend. When I was driving there the radio was working. I spent 2 days in Tahoe and on the way home, my radio stopped working. It was pretty cold there.
    Could it be that the cold or altitude affected something and the radio lost power, and then two days later it went back to normal?:confused:
     
  7. Asim Jahangir

    Asim Jahangir Junior Member

    Joined:
    Aug 10, 2012
    34
    0
    0
    Vehicle:
    2007 Prius
    Model:
    Two
    Hi there,

    A few days ago, the radio / audio player on my prius gen II, 2007 stopped working. When I press the audio button on the MFD, I see the Audio Off display. The power button, the radio buttons, or the audio control buttons on the steering do not seem to revive it. The car seems to have lost all audio. While I can connect my phone with the bluetooth, there is no audio when I make a call. All non-audio features of the MFD are working fine.

    I have tried gently pressing the radio face to see if there is restored power but it didn't work. Any ideas what could be going on? Is there a fuse that I should check? What else should I do?

    thanks in advance,
    Asim
     
  8. jimvitz

    jimvitz Junior Member

    Joined:
    Dec 4, 2003
    94
    0
    0
    Location:
    Oak Park, IL
     
  9. jimvitz

    jimvitz Junior Member

    Joined:
    Dec 4, 2003
    94
    0
    0
    Location:
    Oak Park, IL
    Don't know if it's the same issue, but my 2010 Prius sound system stopped working too. Toyota wanted $3000 to replace the entire nav screen. They told me that's what there "codes" told them. After troubleshooting lots of possibilities, I concluded it was the amplifier. Bought one on eBay for $100, and now the problem is solved. Don't take toyota's word on this one!
     
Loading...