1. Attachments are working again! Check out this thread for more details and to report any other bugs.

Rebuilt Combo meter..signal stuck on..help

Discussion in 'Gen 2 Prius Technical Discussion' started by dirt657, Jun 20, 2019.

  1. dirt657

    dirt657 Member

    Joined:
    Dec 1, 2018
    159
    42
    0
    Location:
    Arroyo Grande, CA
    Vehicle:
    2010 Prius
    Model:
    N/A
    I took the cash apart and got out this combo meter, took it apart, resoldered a new capacitor, reinstalled everything and just put the dash in and connected it to test and the turn signal light is stuck on. Any ideas? Did not spill solder anywhere! Very important I need to drive this car.
     

    Attached Files:

  2. Skibob

    Skibob Senior Member

    Joined:
    Sep 14, 2018
    2,912
    1,493
    0
    Location:
    Northern California
    Vehicle:
    2006 Prius
    Model:
    N/A
    I’m guessing you did bridge something.
     
  3. dirt657

    dirt657 Member

    Joined:
    Dec 1, 2018
    159
    42
    0
    Location:
    Arroyo Grande, CA
    Vehicle:
    2010 Prius
    Model:
    N/A
    If I took a picture of the board would you be able to tell?
     
  4. Skibob

    Skibob Senior Member

    Joined:
    Sep 14, 2018
    2,912
    1,493
    0
    Location:
    Northern California
    Vehicle:
    2006 Prius
    Model:
    N/A
    Not me. I’ve never done it myself. @Texas Hybrid Batteries might be able to though. He rebuilds them all the time.
     
  5. dirt657

    dirt657 Member

    Joined:
    Dec 1, 2018
    159
    42
    0
    Location:
    Arroyo Grande, CA
    Vehicle:
    2010 Prius
    Model:
    N/A
    How hard is he to reach?
     
  6. Skibob

    Skibob Senior Member

    Joined:
    Sep 14, 2018
    2,912
    1,493
    0
    Location:
    Northern California
    Vehicle:
    2006 Prius
    Model:
    N/A
    Well I sent up the bat signal for him. He has a website you could try there.
    Texas Prius Battery Replacement
     
  7. dirt657

    dirt657 Member

    Joined:
    Dec 1, 2018
    159
    42
    0
    Location:
    Arroyo Grande, CA
    Vehicle:
    2010 Prius
    Model:
    N/A
    @Texas Hybrid Batteries was INCREDIBLY helpful in helping me sort out my issue. I had mixed up the circuit boards as I was doing two at once.
     
    fotomoto likes this.