Red triangle/check (actuator problem) engine light battery placed 2016

Discussion in 'Gen 2 Prius Main Forum' started by Kmtomlin, Feb 12, 2019.

  1. Kmtomlin

    Kmtomlin New Member

    Joined:
    Feb 7, 2019
    5
    0
    0
    Location:
    Austin, Tx
    Vehicle:
    2004 Prius
    Model:
    N/A
    Hey all!

    2004 Prius/non sks 12v fine

    So the issue I'm have is the red triangle suddenly appeared. In addition, my brake actuator is going out. Pulled the codes and mechanic is replacing it on friday. No battery codes came up.

    Since yesterday I've had the red triangle and a check engine light pop up(in addition to the brake ((!)) And abs lights that were already up from the actuator.

    What could be going on? Hybrid battery was replaced in 2016(before I bought it but I have paperwork) with a one year warranty. 12v is reading fine. What could this possibly be? Any suggestions on things to do?
     
  2. fotomoto

    fotomoto Senior Member

    Joined:
    Apr 22, 2009
    4,357
    2,704
    0
    Location:
    So. Texas
    Vehicle:
    Other Hybrid
    Red Flag. Unless it's a genuine new Toyota battery, I'd wager it's a refurbished (expensive sounding word for used) pack that has died (again). You'll need to get the trouble codes read (with a reader capable of reading hybrid codes) as we'd just be guessing till then. Worst case scenario is it's both.

    GOOD LUCK!
     
    SFO likes this.
  3. SFO

    SFO Senior Member

    Joined:
    Feb 7, 2017
    1,453
    1,586
    0
    Location:
    Northern California
    Vehicle:
    2007 Prius
    Model:
    N/A
    Check the fluids lately? o_O
     
    Skibob likes this.
Loading...