Red triangle light and check engine lights on

Discussion in 'Gen 2 Prius Technical Discussion' started by Lemonlizard, Oct 10, 2021.

  1. Lemonlizard

    Lemonlizard New Member

    Joined:
    Dec 15, 2020
    4
    0
    0
    Location:
    It's a mystery!
    Vehicle:
    2005 Prius
    Model:
    N/A
    Hey guys!

    I've had my 2005 Prius for about a year and a half now, and it's been a mixed experience. For some background: when I bought it the dealership replaced the hybrid battery for me as it was dead, which was nice. I also found out that the coolant control valve needed to be replaced, but as my daily commute was about a mile or two at the time, I drove on it for a while and finally got it replaced back in I think May. Everything was fine after that. I'm going out of town on Friday and it's a 400 mile drive each way, so about two weeks ago I got the oil changed, tired rotated, and had my brakes checked. Firestone said the brakes were fine and everything else went great. I didn't have any issues up until yesterday.

    I was driving down the highway and suddenly, the red triangle warning, VSC, (!), and check engine lights came on at the same time. On my way back home, driving slowly and carefully, the ABS light came on and it started beeping when I approached a red light. It only stayed on briefly, came back on and beeped some more at the next light, then after that I was home. A buddy of mine used his diagnostic tool on my car and interestingly, he said there was no ABS history being shown, just the P1121 error again. I drove another maybe 30 miles on it after that and while the warning lights are on, the ABS thankfully didn't start beeping again. It felt okay to drive - there was an odd crunching noise that came from the front passenger's side when braking, but that went away after a while. The AC was blowing warm air briefly despite being on max cold, but once night time came around it blew cold air again. I did the 12v battery self test a few minutes ago and the numbers were all within normal range.

    What do you guys think might be going on? The replacement coolant valve I bought felt like it was decent quality. Is it normal for those to break down in less than 6 months? Could a battery cell be dying? Maybe it's just had enough of everything, haha :LOL:

    The big question though is: do you think it's safe to drive another ~800+ miles on it? I'm working 8-8 shifts all week with an hour commute each way and have to leave early Friday morning, so I just won't have the time to take it anywhere until... phew, the 20th at the earliest. I don't think a mini-VCI would get here before Friday even if I ordered one right now - I could use Torque Pro with any old Bluetooth OBD2 scanner, right? Since I'm not too sure what my friend used and if it could pick up potential battery issues.

    Sorry this is such a long post, I wanted to be as detailed as I could :oops:

    Thanks!
     
  2. Lemonlizard

    Lemonlizard New Member

    Joined:
    Dec 15, 2020
    4
    0
    0
    Location:
    It's a mystery!
    Vehicle:
    2005 Prius
    Model:
    N/A
    Huh, haha, both warning lights turned themselves off last night and haven't come back on since. Maybe I'm in the clear...? :LOL:
     
  3. Lemonlizard

    Lemonlizard New Member

    Joined:
    Dec 15, 2020
    4
    0
    0
    Location:
    It's a mystery!
    Vehicle:
    2005 Prius
    Model:
    N/A
    It happened again.... The AC was running fine, but as I was driving the same four lights came on then the AC died. I turned around because a friend is letting me borrow their car, and as I was getting closer to their place, the ABS started beeping again, but then the brakes started feeling weird. Like they weren't responding as well. What could be happening?
     
Loading...