Reseated a fuse and now I get P0658 - anything I can try or bring to an auto mechanic?

Discussion in 'Gen 4 Prius Technical Discussion' started by envin, Jul 7, 2021.

  1. envin

    envin New Member

    Joined:
    Jul 6, 2021
    2
    0
    0
    Location:
    Massachusetts
    Vehicle:
    2018 Prius
    Model:
    Two
    First time posting,

    I have a 2018 prius that has an aftermarket pioneer receiver with Carplay. I did a round trip Massachusetts -> Florida trip last month and on my way back, my pioneer screen turned off.
    It would not turn back on.

    A few days later when I got home, the internet said the first thing to check was the fuse. It seemed pretty simple, so I wanted to give that a try.
    I reseated the fuses in the interior, I didn't realize which one it was until later, so I reseated most of them. After that, I turned my car on and the radio turned on!

    But also the engine light came on...
    I picked up an OBD2 diagnostic tool from Amazon and it is giving me a P0658 diagnostic code. I picked up a fuse tester and I want to go one by one to test all of them.

    I wanted to get some opinions before I try a few other things. I own my car and I love tinkering but at some point, it may be out of my comfort zone.
     
  2. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    99,921
    45,284
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    you really need a prius aware scanner like tech stream. try disconnecting the h/u, and the12v neg, then reconnect the 12v neg and see if the lite comes back on
     
  3. envin

    envin New Member

    Joined:
    Jul 6, 2021
    2
    0
    0
    Location:
    Massachusetts
    Vehicle:
    2018 Prius
    Model:
    Two
    I just did this. Disconnected the head unit and battery. Reconnected and same error from the scanner I have. I also posted a picture of what I’m seeing on the dash itself.

    Is there any benefit of testing each fuse?
     

    Attached Files:

  4. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    99,921
    45,284
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    it sounds like the new h/u is causing a problem, or bad wiring. not all scanners work correctly on prius due to the shear number of ecu's an d communication protocols
     
Loading...