Splash guard problems

Discussion in 'Gen 3 Prius Care, Maintenance & Troubleshooting' started by barbaram, Feb 12, 2014.

  1. barbaram

    barbaram Active Member

    Joined:
    Jan 24, 2006
    911
    69
    9
    Location:
    Trenton, NJ
    Vehicle:
    2010 Prius
    Model:
    IV
    Yes, we are having a tough winter. I've had a Prius since 2006, and bought the 2010 in 2009 when it came out. This is the first winter I'm having a problem with the splash guards under the engine coming loose and hanging down.. I went to the dealer on 1/27 and had them put back in place. I went back again on 2/10. I looked under the car and again one side is hanging down. They dealer explained that it is a plastic clip that holds them in place. I don't drive over big lumps of snow & ice.
    I'm wondering if anyone else is having this problem. I have a call in to the service manager asking if they have a sturdier guard that can replace the current ones.
    Other than moving to a non-snowy place , would appreciate your suggestions!
    Thanks!
     
  2. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    99,921
    45,284
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    see my post on your other thread. pchat seems to be doing a lot of dupe threads lately.
     
  3. SHERYLKEMMERER

    SHERYLKEMMERER Junior Member

    Joined:
    Oct 17, 2011
    1
    0
    0
    Location:
    Royersford PA
    Vehicle:
    2011 Prius
    Model:
    Three
    Barb, My splash guard had a bolt loose but after the10 inches of snow we had in PA , the whole front piece dropped down while driving. I pulled over and luckily found 2 bungee I had stored and crawled under hooking them to holes near the front wheels and up to the grill. It looks real classy (joking). At least I can drive it until I figure out how to fix it.
     
Loading...